WordPress.org

Plugin Directory

Google AdSense

The official AdSense Plugin, written by Google. Supported products include AdSense and Webmaster Tools. Previously Google Publisher Plugin.

20 Feb 2015, Plugin version 1.1.0

  • Ads can now be placed on custom page templates.

13 Jan 2015, Plugin version 1.0.2

  • Fixed a bug that caused newly created pages on some themes to be incorrectly recognized as using custom page templates.

16 Dec 2014, Plugin version 1.0.1

  • Fixed two remaining occurrences of the previous plugin name.

11 December 2014

The following change does not require a plugin update, and was fixed server-side.

  • Full roll out of Automated Mobile Ads.

8 December 2014, Plugin version 1.0.0

Renamed the plugin from "Google Publisher Plugin" to "AdSense Plugin", and moved it out of beta.

10 November 2014

The following changes do not require a plugin update, and were fixed server-side.

  • Link units are no longer recognized as regular ad units by the plugin. This makes it possible to place three ads on a template using the plugin regardless of the number of link units.
  • It is now possible to temporarily place more than three ads per template in design mode. The additional ad units must be removed before saving.
  • Fixed a bug that made it impossible to remove or modify a placement placed above a paragraph that no longer existed. Posts and pages with a small number of paragraphs will now have additional placeholder paragraphs in design mode.

2 October 2014

The following changes do not require a plugin update, and were fixed server-side.

  • Added more ad placements options between sidebar widgets.
  • Fixed a common incompatibility with the "WordPress SEO by Yoast" plugin. This bug made page analysis fail with a "cache error" when the date-based archives were disabled.

19 Aug 2014, Plugin version 0.3.0

  • Exclude pages from having ads on them.
  • Support to deliver ad layout updates from Google in order to, for example, fix broken layouts.

The following changes do not require a plugin update, and have been fixed server-side.

  • Ad placements are automatically populated for each template for new users.
  • Manually insert ads in locations that you determine yourself. This gives you all the power of manually adding ad slots, yet retains the ease of use of the plugin.

27 May 2014, Plugin version 0.2.0

  • A notification will now be shown on the WordPress dashboard when one or more ads are not appearing correctly (for example, because the theme has changed). Note that these notifications are currently only updated once a day.
  • Ads will now only be shown on the theme they were placed on. For example, when a separate theme is used for mobile devices, ads will no longer be shown on that theme.
  • Fixed an incompatibility with a number of other plugins.
  • Extended the nonce lifetime, which should reduce the number of failed saves.

1 May 2014

The following changes do not require a plugin update, and were fixed server-side.

  • Ad units created by the plugin now have understandable names in AdSense, such as "Front page - 1 (yoursite.com)".
  • Added support for placing ads on "Tags" and "Category" pages.
  • Fixed miscellaneous errors when computing possible placements.
  • Improved error messages for various failures.

30 Jan 2014

The following changes do not require a plugin update, and were fixed server-side.

  • No longer show dynamicgoogletags.update() in post content if the theme incorrectly strips HTML.
  • Added support for sites with mixed case URLs.
  • Fixed bug related to preview of vertical ads.
  • Improved margins on ad placements.
  • Inverted marker for placement at the top of the page to point at the correct location for placement.
  • Added support for sites that use HTTPS but are administered over HTTP.
  • Update the view, specifically ad sizes, when user resizes the window in preview mode.
  • Fixed miscellaneous errors when computing possible placements.
  • Localized AdSense help center pages for the plugin.

15 Jan 2014, Plugin version 0.1.0

  • Initial release.

Requires: 3.5 or higher
Compatible up to: 4.2.2
Last Updated: 2015-4-21
Active Installs: 90,000+

Ratings

3.4 out of 5 stars

Support

0 of 12 support threads in the last two months have been resolved.

Got something to say? Need help?

Compatibility

+
=
Not enough data

2 people say it works.
0 people say it's broken.

100,1,1
100,1,1
0,4,0
20,5,1
20,5,1
20,5,1
46,28,13
35,23,8
0,1,0
71,7,5
80,5,4
78,9,7 100,1,1
100,1,1 100,1,1
100,1,1 60,5,3
100,1,1 88,8,7
100,2,2