WordPress.org

Plugin Directory

Test out the new Plugin Directory and let us know what you think.

GloboMailer Email Marketing Automation

Connect your WordPress Install with GloboMailer and create email marketing automation. Also use your GloboMailer account and send transactional emails

GloboMailer’s official plugin for WP is a powerful all-in-one email marketing plugin. At a glance:

  • Subscribe forms - Create custom subscribe forms and integrate them easily in your posts, pages or sidebars
  • Contact lists - Manage your contact lists and take advantage of advanced segmentation to improve your campaigns performance
  • Marketing campaigns - Easily create and send beautiful newsletters using drag and drop builder or selecting from our template library
  • Transactional emails - The wp_mail() function use automatically GloboMailer’s SMTP for enhanced deliverability and tracking

Subcribe forms

  • Form designer with direct HTML / CSS editor if needed
  • Integration as widget or shortcode [GloboMailerEMA namefield=YES desc="" list=UNIQUE-LIST-ID-HERE]
  • Confirmation email - you choose the template and the sender
  • Double optin - you choose the template and the sender
  • URL Redirection
  • Confirmation / error message customization

Contact Lists

  • Folder and lists management
  • Files import
  • Custom fields
  • Advanced segmentation. Example: Contacts below 30 years who clicked on the link 3 of my last campaign

Marketing campaigns

  • Responsive design newsletter builder (drag & drop)
  • Advance newsletter builder
  • Subject and content personalization. Example: Hello {FNAME}
  • Inbox and multi-clients rendering tests
  • Campaign programming

Transactional emails & statistics

  • Automatic replacement of default SMTP when you use wp_mail function
  • Create transactional email templates easy to reuse from API
  • Real time and exhaustive statistics: delivered, opens, clicks, etc.

Plugin Support

To get support, please send an email to support@globomailer.com, we will be happy to help you!

The plugin is available in English.

Requires: 3.0 or higher
Compatible up to: 4.2.12
Last Updated: 2 years ago
Active Installs: 20+

Ratings

5 out of 5 stars

Support

Got something to say? Need help?

Compatibility

+
=
Not enough data

0 people say it works.
0 people say it's broken.

100,1,1 100,1,1