WordPress.org

Plugin Directory

Test out the new Plugin Directory and let us know what you think.

Gallery Shortcode Style to Head

Moves the gallery shortcode styles to the head so it doesn't break XHTML validation; allows disabling or modifying the default gallery styles.

2.4 (2015-03-02):

2.3 (2013-03-08):

  • Corrected 'undefined varibale' notice and RTL language detection.
  • Now requires WordPress 3.0 or higher.

2.2 (2012-12-11):

  • Support for WordPress 3.5 and its improved galleries.

2.1 (2011-01-15):

  • Removed clearing br tags in galleries (replaced with clearing div tags).
  • Corrected bug that threw a cryptic error on the media page for some users.
  • Support for WordPress 3.1; now requires WordPress 2.9 or higher.

2.0 (2010-05-02):

  • New gallery style settings on the Admin > Settings > Media page.
  • Ability to modify the default gallery styles.
  • Ability to disable the default styles entirely (so you can style the gallery in your template CSS).
  • Support for WordPress 3.0; now requires WordPress 2.7 or higher.

1.3 (2010-02-09):

  • Re-Sync with WordPress 2.9 gallery code for support of the new 'include' and 'exclude' options.

1.2 (2009-09-20):

  • Corrected function of 'Link thumbnails to...' setting on galleries when this plugin is enabled.

1.1 (2008-09-22):

  • Added filter so that the default style can be overridden.

1.0 (2008-08-27):

  • Initial Public Release

Requires: 3.3 or higher
Compatible up to: 4.1.15
Last Updated: 2 years ago
Active Installs: 600+

Ratings

0 out of 5 stars

Support

Got something to say? Need help?

Compatibility

+
=
Not enough data

0 people say it works.
0 people say it's broken.

100,2,2
100,3,3
100,1,1
50,2,1
0,1,0