This plugin hasn’t been updated in over 2 years. It may no longer be maintained or supported and may have compatibility issues when used with more recent versions of WordPress.

FTP Upgrade Fix

Description

Some server configurations running Pure-FTPd have trouble updating WordPress via FTP. Common error messages when trying to update WordPress or update/install a plugin look like this:

  • Could not copy file.: /wp-admin/css/theme-editor.dev.css
  • Could not copy file.: /public_html/wp-admin/css/theme-editor.dev.css
  • Could not copy file.: /…/…/wp-admin/css/theme-editor.dev.css
  • Could not create file.: /public_html/

Each of these cases seem to be related. There is a patch going into WordPress 3.2 that should take care of the issues and the plugin will be obsolete after updating to that version (https://core.trac.wordpress.org/ticket/10913). In the meantime, install and activate this plugin. Updates should work as expected.

Installation

Upload the FTP Upgrade Fix plugin to your blog via FTP and Activate it.

Contributors & Developers

“FTP Upgrade Fix” is open source software. The following people have contributed to this plugin.

Contributors

Translate “FTP Upgrade Fix” into your language.

Interested in development?

Browse the code, check out the SVN repository, or subscribe to the development log by RSS.

Changelog

1.0

  • Initial release