WordPress.org

Plugin Directory

FireStorm Shopping Cart eCommerce Plugin

This professional eCommerce plugin gives you the ability to run an advanced online store with an easy to use shopping cart.

Requires: 3.0 or higher
Compatible up to: 3.6.1
Last Updated: 2013-12-1
Active Installs: 30+

Ratings

3 out of 5 stars

Support

0 of 1 support threads in the last two months have been resolved.

Got something to say? Need help?

Compatibility

+
=
Not enough data

0 people say it works.
0 people say it's broken.