Plugin Directory

FireStorm Shopping Cart eCommerce Plugin

This professional eCommerce plugin gives you the ability to run an advanced online store with an easy to use shopping cart.

Version 2.07.02

  • Misc. bug fixes.

Version 2.07.01

  • Misc. bug fixes.

Requires: 3.0 or higher
Compatible up to: 3.6.1
Last Updated: 2 years ago
Active Installs: 20+


3 out of 5 stars


Got something to say? Need help?


Not enough data

0 people say it works.
0 people say it's broken.