WordPress.org

Plugin Directory

Test out the new Plugin Directory and let us know what you think.

Front End PM

Front End PM is a Private Messaging system and a secure contact form to your WordPress site.This is full functioning messaging system from front end.

How to update?

DO NOT UPDATE IN PRODUCTION SITE BEFORE TEST IN STAGING SITE. Please full backup first before update.

Lost messages after update from FEP Version 3.3 or less

If you update from FEP version 3.3 or less after update FEP please go to Dashboard > Front End PM > Settings > Update. This will update your messages. (also after successfully update messages it will delete it's database tables ).

FEP version 4.0+ do not use its database table anymore. It use CPT.

If you have many messages and update do not work correctly use following method. Replace front-end-pm > admin > class-fep-update.php with class-fep-update.php. DO NOT USE THIS FILE IN PRODUCTION BEFORE TEST IN STAGING SITE. Go to dashboard > Front End PM > Settings > Update and click "Start Update" JUST ONCE.It may take time as you have many messages.

Can i use this plugin to my language?

Yes. this plugin is translate ready. But If your language is not available you can make one. If you want to help us to translate this plugin to your language you are welcome. please use wordpress translation.

Where is "FEP Contact Form" which was added from version 2.0?

"FEP Contact Form" is now a separate plugin from version 3.1, so that you can use that plugin with "Front End PM" or without.

Why code comments is less?

I am very busy with my job. In my leisure i code for plugins. If you want to help to add comments to the code or indentation you are welcome. https://github.com/shamim2883/front-end-pm/.

Where to contact for paid support?

You can visit Front End PM and contact with me for paid support.

Requires: 4.4 or higher
Compatible up to: 4.6.1
Last Updated: 2 weeks ago
Active Installs: 5,000+

Ratings

4.8 out of 5 stars

Support

12 of 18 support threads in the last two months have been marked resolved.

Got something to say? Need help?

Compatibility

+
=
Not enough data

0 people say it works.
0 people say it's broken.

100,1,1
100,1,1 100,1,1
100,3,3 100,2,2 100,2,2
100,1,1
100,1,1
100,2,2
100,1,1
100,1,1
100,1,1
100,1,1
100,1,1
100,1,1
100,1,1
83,6,5
0,1,0
100,2,2
100,1,1
100,2,2
100,1,1
100,1,1