WordPress.org

Plugin Directory

Font Emoticons

Replaces WordPress' smileys with font-based emoticons.

1.4.1

  • Feature: Added general purpose filter called wp_font_emots_replace. This filter can be used to replace emoticons in places not supported by this plugin.

1.4.0

  • Feature: Implemented rudimentary bbpress support. I don't use bbpress, so some parts may still no display emoticons correctly. (issue #10)
  • Feature: Emoticons are now also replace in the text sidebar widget.
  • Fix: emoticons.css no longer gets an unnecessary ?v= parameter attached (WordPress does this automatically on its own); also made the style's name more unique so that it's less likely to conflict with other plugins.
  • Fix: Replaced usage of internal constant WP_PLUGIN_URL with plugins_url()

1.3.1

  • Fix: Self closing span (<span/>) seems to be invalid in some cases. Replaced it with regular <span></span> (issue #8)

1.3

  • Feature: New emoticon "squint": |) or :squint:
  • Feature: Added some general purpose icons like <3 (heart) or :thumbsdown: (:thumbsup: got changed to icon from emoticon)
  • Change: PHP 5.3 is now required
  • Change: "devil" and "eek" got more text representations; "smile" now also supports the Australian version (-:
  • Change: Made font and css classes more unique so that they don't interfer with other icon fonts (issue #7)
  • Fix: Multiple consecutive emoticons are now parsed correctly (issue #5); emoticons surrounded by HTML tags (like <li>:)</li>) are now parsed correctly.
  • Fix: Wider emoticons now flow correctly with surrounding text (no longer overlap it) (issue #4)

1.2

  • Emoticons are now supported in comments and excerpts. (issue #1)

1.1

  • Emoticons are no longer replaced in URLs. Instead they now require surrounding white space.
  • Emoticons at the beginning and the end of posts are recognized now.

1.0

  • First release.

Requires: 3.0.0 or higher
Compatible up to: 4.2.3
Last Updated: 2015-6-13
Active Installs: 1,000+

Ratings

4.9 out of 5 stars

Support

2 of 2 support threads in the last two months have been resolved.

Got something to say? Need help?

Compatibility

+
=
Not enough data

0 people say it works.
0 people say it's broken.

100,1,1 100,2,2
0,1,0 50,2,1
100,1,1
100,1,1
100,2,2
100,1,1
100,2,2
100,2,2
100,1,1 100,1,1
100,1,1
100,1,1 100,1,1