WordPress.org

Plugin Directory

Font Awesome Shortcodes for WordPress

Implements the Font Awesome icon font in WordPress through shortcodes.

4.2

  • Icon Picker now supports new icons and aliases added in Font Awesome 4.2 (see Font Awesome site for details)
  • Better correct for conflicts with Gravity Forms --these two plugins should finally play well together
  • Removed use of extract() to better fit with WordPress's best practices.

4.1.3

  • Added [fa-ul] shortcode (see documentation for details).
  • Add Font Awesome shortcode help popup button to Distraction Free Writing Mode toolbar
  • Better responsive styles for help popup button on smaller screens
  • Fix display problems for WP-Engine users
  • Better handling of Gravity Forms' "No Conflict Mode"
  • Fix conflict with All-In-One Events Calendar
  • Fix for some situations where the help-tab popup would be behind other popup elements.
  • WordPress 4.0 support!

4.1.2

  • Fix display problem where the Font Awesome Shortcodes help modal was appearing on pages it shouldn't

4.1

  • This release features a brand new, much easier to use popup for the documentation. We're now using Bootstrap's "modal" component rather than the soon-to-be-retired WordPress Thickbox. We've also split the documentation up into tabs so that the technical information about the plugin isn't cluttering up the shortcode reference material. This should make the plugin a little less scary for end-users.
  • Support for new icons and aliases added in Font Awesome 4.1 (see Font Awesome site for details)

4.0.3.8

  • Tested to work in WordPress 3.9
  • Fix jQuery errors in FireFox
  • Fix media button icon in Internet Explorer

4.0.3.7

  • Fix errors with included Markdown parser

4.0.3.4

  • Bug fixes and changes to play nice with other plugins
  • Rewrite to better escape input

4.0.3.3

  • Fix some icons not showing properly in the icon picker

4.0.3.2

  • Fix admin styles loading on front-end pages

4.0.3.1

  • Fix help tab styles

4.0.3.1

  • Fix help tab popup on edit pages

4.0.3

  • Initial WordPress.org release

Requires: 3.8 or higher
Compatible up to: 4.0.1
Last Updated: 2014-11-29
Active Installs: 2,000+

Ratings

4.3 out of 5 stars

Support

Got something to say? Need help?

Compatibility

+
=
Not enough data

0 people say it works.
0 people say it's broken.

100,1,1
100,1,1