WordPress.org

Plugin Directory

!This plugin hasn't been updated in over 2 years. It may no longer be maintained or supported and may have compatibility issues when used with more recent versions of WordPress.

Feed Stats for WordPress

A plugin that seamlessly integrates detailed FeedBurner stats into your WordPress blog's dashboard.

1.0.6

  • Removed the scary Google FeedBurner error messages--Google fixed their Awareness API issues.
  • Fixed the bug (reported by Bjoern Buerstinghaus) where both the Feed Stats options and Feed Stats stats pages' navigation menu items would be highlighted at the same time when either of those pages were viewed.
  • Made the plugin fully translatable.
  • Improved code cleanliness and documentation.
  • Rewrote parts of the code that loads information from FeedBurner to improve performance; it now makes only two data requests (1.0.5 made four) to FeedBurner when the stats page is loaded.
  • Set cache headers on the CSS file to improve performance.
  • Improved compatibility with Windows servers.
  • Formatted the dates in the tables below the charts according to the date format option set in WordPress to increase readability.
  • Added Bjoern Buerstinghaus's fantastic translation of the plugin into German.
  • Improved initial user experience by improving the messages to the user.
  • Improved code quality by writing tests (using the SimpleTest PHP toolkit) to ensure that the code works properly.

1.0.5

  • A new HTTP engine (Troy Wolf's class_http) that should offer more consistency across WordPress versions.
  • FeedBurner vs. Google FeedBurner detection code to ease the transition to Google.
  • Improved error messages.
  • Templated CSS (to improve consistency across versions of WordPress).
  • CSS updates to make the plugin feel more at home in WordPress 2.7+.
  • More robust detection of the availability of reach stats.
  • The feed tester is now run in the domain of the WordPress admin panels. This should allow it to run under more configurations of WordPress and improve security.
  • External script access of internal PHP scripts is now blocked (using a similar method to CodeIgniter).
  • Improved internal documentation.
  • Proper ChangeLog documentation.
  • A proper GPL COPYING file has been added.

Requires: 2.3.3 or higher
Compatible up to: 2.9.2
Last Updated: 2009-7-30
Active Installs: 1,000+

Ratings

0 out of 5 stars

Support

Got something to say? Need help?

Compatibility

+
=
Not enough data

0 people say it works.
0 people say it's broken.

100,2,2
100,1,1
67,3,2
100,1,1
0,2,0
0,1,0
0,1,0