Plugin Directory

!This plugin hasn’t been updated in over 2 years. It may no longer be maintained or supported and may have compatibility issues when used with more recent versions of WordPress.

External Related Links

This plugin is used for those who want to show some related links in posts/pages, and those related links is external (outside the blog site).

Requires: 2.0.2 or higher
Compatible up to: 2.6
Last Updated: 2008-10-22
Active Installs: 50+


0 out of 5 stars


Got something to say? Need help?


Not enough data

0 people say it works.
0 people say it's broken.