WordPress.org

Plugin Directory

Test out the new Plugin Directory and let us know what you think.

Etsy Shop

Plugin that allow you to insert Etsy Shop sections in pages or posts using the bracket/shortcode method.

0.18

  • Add version for css file
  • Compatible with WP 4.5

0.17

  • Automatically detect GBP currency
  • Compatible with WP 4.3

0.16.2

  • Correction for show_available_tag

0.16.1

  • Mistake, default columns is 3, not 4
  • You can add columns="5", to your short code. Replace number 5 by the number you want

0.16

  • Option to select number of columns to show
  • Option to select a single listing ID
  • Option to height & width of thumbnail
  • Option to choose thumbnail size
  • CSS Update
  • Portion of code from Steague, thanks!

0.15

  • Add Option to choose translation language for the content
  • Automatically choose Dollard Sign or Euro sign

0.14

  • Italian Translation (thanks to Pierantonio Bonato)
  • Compatible with WP 4.2.1

0.13.1

  • Correct old shortcode method to avoid PHP Warning

0.13

  • Option to show or not the Available Status Tag for each item

0.12

  • Permit reset of the cache in the admin page (sponsor Michael Kellar)

0.11

  • Add the option to change time out value for requests to etsy servers
  • Time out value by default is 10 seconds instead of 5

0.10

  • Compatible with WP 3.9.2
  • Now use WP Shortcode API
  • Allow maximum of 100 items per section instead of 25 items

0.9.5

  • HTTPS for all Etsy requests, now mandatory for new Etsy Apps.
  • Add detection for bad section ID.

0.9.4

  • Centering items by default (sponsor Jsay Designs).
  • Add opening in a new window link feature (sponsor Jsay Designs).
  • Add filter for Shop ID and Section ID.
  • Better filter for API Key.

0.9.3

  • Corrections on Debug Mode.
  • Automatically Remove spaces in API Key.

0.9.2

  • Debug Mode more verbose.

0.9.1

  • Debug Mode available.
  • Options page compatible with PHP 5.2.X.

0.9.0

  • Optimization of API request.
  • Add error message if empty arguments.
  • Now using WordPress HTTP API, cURL is no more require.
  • Update the Options Page.
  • Code follow WordPress Coding Standards.

0.8.1

  • Update installation steps.
  • Translation of listing status.
  • Correct listing table generation.

0.8

  • First release.

Requires: 3.4.2 or higher
Compatible up to: 4.5.4
Last Updated: 8 months ago
Active Installs: 4,000+

Ratings

4 out of 5 stars

Support

0 of 1 support threads in the last two months have been marked resolved.

Got something to say? Need help?

Compatibility

+
=
Not enough data

0 people say it works.
0 people say it's broken.

100,1,1
0,1,0
100,1,1
100,1,1 100,1,1 100,1,1 100,1,1
100,2,2
100,1,1 67,3,2
100,1,1
100,1,1
100,1,1
100,1,1 100,1,1
100,1,1 100,1,1
100,1,1
100,1,1
100,1,1
100,1,1
100,1,1