Plugin Directory

!This plugin hasn’t been updated in over 2 years. It may no longer be maintained or supported and may have compatibility issues when used with more recent versions of WordPress.

EP Admin Messages

Show messages in WP Admin. Different messages can be shown at different places, for different people.


  • Allow installation for php 5.3 or higher. Prev was set to higher than 5.3 (but not including 5.3).


  • Fixed a notice warning when creating new post


  • Bump version because I can't use SVN properly...


  • Added support for limiting messages to users based on their role. Usage: user_role: "editor,author"
  • Added support for custom title in metaboxes. Usage: "title": "This is the title of the message"


  • Added support for limiting messages to users based on their ID or their username. Usage: ```username: "admin"``


  • Use .ep-config.json instead of ep-config.json for configuration file. Makes it a bit more secure, since dot-files often are hidden and protected by default.
  • Example config config-example.json updated with better examples and is now in english.
  • Fixed bug with notice warning when creating new posts.
  • Added screenshots.


  • First working version.

Requires: 3.6 or higher
Compatible up to: 3.7.16
Last Updated: 3 years ago
Active Installs: 50+


3.3 out of 5 stars


Got something to say? Need help?


Not enough data

0 people say it works.
0 people say it's broken.

0,1,0 100,1,1