WordPress.org

Plugin Directory

Enhanced Media Library

A better management for WordPress Media Library

Requires: 4.0 or higher
Compatible up to: 4.2.2
Last Updated: 2015-5-2
Active Installs: 30,000+

Ratings

4.8 out of 5 stars

Support

5 of 18 support threads in the last two months have been resolved.

Got something to say? Need help?

Compatibility

+
=
Not enough data

2 people say it works.
1 person says it's broken.

100,5,5 100,2,2
75,4,3 100,3,3
100,6,6
0,16,0 100,3,3
67,6,4 100,2,2
100,4,4 100,1,1
100,2,2
100,1,1 100,1,1
100,1,1 100,2,2
67,3,2