Plugin Directory

Emma for WordPress

The Emma WordPress plugin allows you to quickly and easily add a signup form for your Emma list as a widget or a shortcode.

  1. How do I put the form on my website?

    Once you have activated the plugin, setup your Emma account to work with their new API, and configured your Emma for WordPress Settings, you have two options for adding the form to your site.

    Widget If you would like to add the form to a widget area, navigate to Appearance->Widgets. This plugin comes with a widget called 'Emma for WordPress Subscription Form'. The Widgets are listed in alphabetical order.

    Shortcode If you would like to add the form to another area on your site, you can use the Emma shortcode. Simply type [emma_form] in the HTML view in the post editor. For more information on shortcodes, check the almighty codex: [Shortcodes](http://codex.wordpress.org/Shortcode" WordPress Codex - Shortcodes").

  2. How do I add members to a specific group?

    Once you've configured the plugin, and entered your account ID, Private and Public API keys, navigate from the Dashboard to Settings -> Emma for WordPress. Under the “Account information” tab there is a dropdown menu under “Add New Members to Group.” From here, you can select the group to which new members should be added.

  3. Can I set up an automated workflow using my WordPress form?

    You sure can. You can have an email send when:

    1. someone subscribes to a specific group from a specific signup form (both configured on the WordPress side)

    2. someone subscribes to a specific group from any signup form (also both configured on the WordPress side)

    3. someone subscribes to any group from any signup form

    Scenarios that won't work are when:

    1. no group is specified in your WordPress plugin (that field isn't required, though we recommend specifying a group so your contacts are added where you can easily send to them)

    2. you don't have any groups in your account (which won't allow you to activate the plugin)

Requires: 3.0 or higher
Compatible up to: 4.3.0
Last Updated: 2015-8-18
Active Installs: 1,000+


3.2 out of 5 stars


Got something to say? Need help?


Not enough data

0 people say it works.
0 people say it's broken.

0,1,0 100,3,3 100,1,1