WordPress.org

Plugin Directory

Email Blaster Newsletter Signup Form

Quickly embed email blaster forms on your WordPress powered site. Add a newsletter signup widget, or any contact form. Easy to use and setup.

Do I need a email blaster account?

Yes, but you can open one for free at email blaster.

How do I build a form?

You can build any form quickly from your email blaster account. Inside your account click on; apps > form builder.

Can I email my subscribers?

Yes, email blaster is free to use. From inside your account, you can email any subscribers which your WordPress site has collected.

How can I see who has joined my mailing list?

New subscribes are automatically added to a mailing list inside your email blaster account. Inside your email blaster account head over to; lists > view lists.

Is there a limit to how many subscribers I can have?

No, it is totally unlimited. You can store as many contacts as you want.

What is a QuickCode?

A QuickCode is a unique code which the email blaster form builder will give you (used to identify your form). It enables you to quickly embed your form inside WordPress without copying hundreds of lines of code. It works in exactly the same was as embedding a YouTube video.

How do I get my QuickCode for WordPress?

On the form builder screen inside email blaster, click 'get code' from the top of the screen. A new window will now open, select 'WordPress'. You will then be given your unique QuickCode to paste into your WordPress widget.

My form is too wide for my WordPress site.

You can quickly adjust the width of your form to fit any WordPress layout. From inside the email blaster form builder select: design frame > width.

If I update my form, do I need to get a new QuickCode?

No, any updates made to your newsletter signup form from inside email blaster will automatically update on your WordPress site (within 60 seconds of saving amends). A QuickCode is valid for the life of your form.

I'm still stuck!

Head over here to visit our contact page. Our team will be happy to assist with any integration queries which you may have. We are lovely people and we don't bite!

Requires: 2.3 or higher
Compatible up to: 4.2.4
Last Updated: 2015-4-27
Active Installs: 1,000+

Ratings

5 out of 5 stars

Support

Got something to say? Need help?

Compatibility

+
=
Not enough data

0 people say it works.
0 people say it's broken.

100,1,1