WordPress.org

Plugin Directory

EDD Third Party and Blog Link

Add extra data to your Easy Digital Downloads products! Indicate if the product is available in the WordPress plugin repository and more.

This plugin requires Easy Digital Downloads. It allows you to add post meta data in Easy Digital Downloads to indicate a third party product as well as a link for more information. Also, it adds a checkbox to indicate if the download is available in the WordPress plugin repository.

Please Note: The plugin doesn't really do anything on it's own. It is for advanced users and does nothing on the front-end without writing your own custom code.

Here is what it does do:

  1. Adds a checkbox to the download configuration for you to indicate that a product is from a third party.
  2. Adds another checkbox to indicate that a product is available on the WordPress plugin repository.
  3. Adds a URL field for you to add an external link to a blog or website for product details or more information.
  4. Stores this data in the download product's post_meta data for you to access and use in your custom code.

Example of how to call the data in your code:

if(get_post_meta( $post_id, 'edd_third_party', true )) {

    echo 'This item is from a third party.' ;

}

if(get_post_meta( $post_id, 'edd_wp_plugin', true )) {

    echo 'This item can be downloaded from WordPress.' ;

}

if(get_post_meta( $post_id, 'edd_bloglink_url', true )) {

    $bloglink = get_post_meta( $post_id, 'edd_bloglink_url', true );
    echo `<a href="' .$bloglink. '" target="_blank">Click for Details </a>`;

}

For more examples and information visit the plugin's blog page: http://butlerconsulting.com/work/plugins/edd-thirdparty-bloglink/.

Translated Languages Available

I was having some fun after upgrading to the pro version of Poedit so I attempted to add Spanish, German, French and Russian translations. I used Google translate and I'm curious to see how it turned out. Please let me know! If you'd like to contribute a translation or report on a poor translation attempt, please let me know on the support forums.

  • Otherwise, the plugin supports American English by Default... Also supports Canadian, British, Scottish, Irish, Australian and a few others (that's a joke)

Requires: 3.1 or higher
Compatible up to: 4.2.2
Last Updated: 2015-5-11
Active Installs: 30+

Ratings

5 out of 5 stars

Support

Got something to say? Need help?

Compatibility

+
=
Not enough data

0 people say it works.
0 people say it's broken.