WordPress.org

Plugin Directory

!This plugin hasn’t been updated in over 2 years. It may no longer be maintained or supported and may have compatibility issues when used with more recent versions of WordPress.

WordPress Local SEO

Boost the Local SEO rankings of your WordPress and optimize the display of your locations: Schema.org, GEO sitemap, Google Maps, infinite locations

2.3

  • renaming the Plugin to WordPress Local SEO
  • optimizing the dscription
  • enabling post content for location post type (optionally)
  • translatable SEO category labels
  • Performance update: Loading only necessary scripts
  • Bugfix: Don't show unpublished locations on website, make trashed locations unavaiable

2.2

  • New: Custom map & logo size, Custom CSS
  • Bugfix: content filter removed original content
  • Bugfix: automatic http:// replace in url fields

2.1

  • Bugfix: faxNumber in location template
  • updated function call to "show_locations" to support multile locations

2.0

  • Advanced configuration: Location as post type, multiple instances added to other post types via post meta
  • Google map with all locations via shortcode or function call
  • Multiple phone & fax numbers, email adresses and websites via dynamic input field
  • set type of location as default through settings or directly in location
  • updated german translation

1.23

  • fixed rewrite bug: renamed to geo_sitemap.xml
  • fixed translation bug in opening hours

1.22

  • updating german translation

1.21

  • no updates

1.20

  • added optional post id to function call and shortcode to extend possibility to show geo location field of a post inside another post
  • changed variable $post->ID to $wpl_id in location-template.php

1.11

  • Bugfix: wp-local-seo.js, wp-local-seo.css included wrong (wp-localseo.js, wp-localseo.css)
  • Bugfix: elements in wp-local-seo.js, wp-local-seo.css named wrong (#dhl)
  • Bugfix: PO-files named wrong

1.1

  • renaming the Plugin to WP Local SEO
  • adding upgrading compatibility

1.0

  • First version

Requires: 3.5.1 or higher
Compatible up to: 3.8.15
Last Updated: 2 years ago
Active Installs: 900+

Ratings

4.5 out of 5 stars

Support

Got something to say? Need help?

Compatibility

+
=
Not enough data

0 people say it works.
0 people say it's broken.

100,1,1