WordPress.org

Plugin Directory

MailChimp Subscribe

MailChimp Subscription Management

This plugin can be installed as any other WordPress plugin.

Requirements

Requires: 3.9 or higher
Compatible up to: 3.9.5
Last Updated: 2014-6-30
Active Installs: 20+

Ratings

0 out of 5 stars

Support

Got something to say? Need help?

Compatibility

+
=
Not enough data

0 people say it works.
0 people say it's broken.