WordPress.org

Plugin Directory

Test out the new Plugin Directory and let us know what you think.

CyberSyn

A powerful, lightweight and easy to use Atom/RSS aggregation and content curation plugin for WordPress with Full Text RSS import feature.

5.26

  • Fixed issue with feed sources that require a browser user agent.

5.25

  • Fixed issue with post thumbnail generation for enclosured images.

5.24

  • Fixed full text RSS feed.

5.23

5.22

  • Google Translate added.

5.21

  • Better media attachment handling.
  • Fully compatible with WordPress 4.7.

5.20

  • Fixed issue with permalinks when the "Link to source" option is enabled.

5.19

  • Yandex Translate added.

5.18

  • Fixed issue with media attachments in shortened excerpts.

5.17

  • "Shorten post excerpts" option added.

5.16

5.15

  • Better compatibility with PHP 7.

5.14

  • Added support for Ustream.tv and DailyMotion video feeds.

5.13

  • Improved Flickr and IGN video feed support.

5.12

  • Added support for Vimeo, Flickr and IGN video feeds.

5.11

  • RSS media attachments of the following types are suppoted now: mp4, m4v, webm, ogv, wmv, flv.
  • Media attachment thumbnails can be used as featured images.
  • Improved compatibility with CyberSEO 7.

5.10

  • Featured image (post thumbnail) generation has been implemented.
  • The plugin is now compatibe with CyberSEO 7.

5.01

5.00

  • Free Full Text RSS feed extractor feature added.
  • Fully compatible with WordPress 4.5.2

4.02

4.01

  • Fixed issue with adding of new feeds.

4.00

  • Fixed CSRF vulnerability.
  • The content spinning feature has been removed by request of WordPress.org.

3.29

  • Fully compatible with WordPress 4.2.2
  • Video import has been adjusted according to the recent youtube API changes

3.28

  • Fully compatible with WordPress 4.1.1

3.27

  • Fully compatible with WordPress 4.1

3.26

  • Fully compatible with WordPress 4.0.1

3.25

  • Fixed issue with WordAi spinner.

3.24

  • Fully compatible with WordPress 4.0.

3.23

  • WordAi support improved.

3.21

  • Fixed bug that caused "Fatal error: Call to undefined function".
  • Fully compatible with WordPress 3.8.1

3.20

  • The plugin is now integrated with WordAi spinner that uses artificial intelligence to understand text and is able to automatically rewrite the syndicated articles with the same readability as a human writer.

3.13

  • Fully compatible with WordPress 3.6.

3.12

  • The default user agent header has been removed from HTTP requests. It was causing problems with FeedBurner feeds.

3.11

  • The Best Spinner integration has been improved.

3.10

  • Added possibility to automatically embed videos from standard YouTube RSS feeds.

3.02

  • Fixed bug which forced the plugin to use "The Best Spinner" even if disabled.

3.01

  • Minor changes.

3.00

  • The plugin is now integrated with TBS (The Best Spinner) - the most popular content spinning service.
  • The post images now can be stored locally (copied to your own host).
  • The syndicated posts now can be attributed to the chosen author.
  • Now one can specify a list of tags for for the each feed.
  • The media attachment handling has been sufficiently improved.
  • The character encoding conversion has been added.
  • Now one can specify the HTML code with will be inserted to the bottom of each syndicated post (so-called post footers).

2.11

2.10

  • The "Link syndicated posts to the original source" option has been added.
  • The RSS auto pull mode now uses the built-in WP pseudo cron.
  • Minor bugs fixed.

2.1

  • All known bugs were fixed.

2.0

  • The CyberSyn plugin is now 100% compatible with WordPress 3.3.
  • The UI has been improved.
  • Default settings have been removed from the "XML Syndicator" page. Use the "Alter default settings" button instead.

1.4

  • The feed import function has been improved. Now the status of 'safe_mode' and 'allow_url_fopen' PHP variables is not important in case if the PHP cURL extension is installed.
  • The user interface has been slightly improved.

1.3

  • "RSS Pull Mode" option switching issue has been fixed.

1.2

  • First public GPL release.

Requires: 4.0 or higher
Compatible up to: 4.7.1
Last Updated: 2 days ago
Active Installs: 8,000+

Ratings

4.7 out of 5 stars

Support

23 of 23 support threads in the last two months have been marked resolved.

Got something to say? Need help?

Compatibility

+
=
Not enough data

1 person says it works.
0 people say it's broken.

100,1,1 100,1,1
100,1,1 100,1,1 100,1,1
50,2,1
100,1,1
100,1,1
100,1,1
50,2,1
100,1,1
100,1,1
100,1,1