This plugin hasn’t been updated in over 2 years. It may no longer be maintained or supported and may have compatibility issues when used with more recent versions of WordPress.

Fast Secure Contact Form Newsletter

Description

The Fast Secure Contact Form plugin now has newsletter support

The Fast Secure Contact form has 5 million downloads, and now — with this add-on plugin — it has easy integration with Constant Contact, the world’s leading email marketing platform!

Setting up newsletter integration is simple:

1. Add your Constant Contact username & password. Save the form.

2. Select the lists you want contacts added to. Save the form.

3. There’s no Step 3.

Note: The plugin requires PHP 5.2 or higher. Constant Contact offers a free 60 day trial, after which time it is a paid service.

What can Constant Contact do for you?

Screenshots

  • The configuration screen of the Fast Secure Contact Form when you have this newsletter plugin installed and activated.
  • Specify how fields are mapped to Constant Contact fields
  • Choose the lists form submissions are sent to

FAQ

What is the plugin license?
  • This plugin is released under a GPL license.

Changelog

2.1.2 (2014-08-26)

  • Fixed: Error on activation caused by loading nameparse.php
  • Removed PressTrends

2.1.1 (2013-12-02)

  • Added a “Refresh Lists” button to fetch new lists from Constant Contact

2.1 (2013-09-13)

  • Added awesome drop-down merge fields menus to Version 4 – now you can specify what fields go where in Constant Contact! Very powerful.
  • Improved name parsing for single-field name fields
  • Cleaned up some code

2.0.8

  • Added PressTrends to help improve compatibility support

2.0.4, 2.0.5 & 2.0.6, 2.0.7

  • Fixed error caused by renaming libraries, introduced in 2.0.3. Sorry about that.

2.0.3

  • Fixes issue with modifying the version number of Fast Secure Contact Form, making it seem like there’s always an update available.
  • Fixes potential conflicts with PHP Constant Contact libraries

2.0.2

  • Fixes conflict with plugins using OAuthException class

2.0 & 2.0.1

  • NOW REQUIRES PHP 5.2 OR HIGHER
  • Supports Fast Secure Contact Form Version 4!, which is coming soon.
  • Also supports version 3.1.8 and higher
  • Updated: Switched to updated API code
  • Updated: Rewrote the plugin to be more solid
  • Fix: Updates existing contact with new lists instead of replacing lists

1.0.1

1.0

  • Blast off!

Contributors & Developers

This is open source software. The following people have contributed to this plugin.

Contributors

Browse the code