WordPress.org

Plugin Directory

Contact Easy

This is the plugin for contacting the owner of website that the data are stored in the wordpress data base.

Requires: 2.9.2 or higher
Compatible up to: 3.8.10
Last Updated: 2014-4-12
Active Installs: 90+

Ratings

0 out of 5 stars

Support

Got something to say? Need help?

Compatibility

+
=
Not enough data

0 people say it works.
0 people say it's broken.

100,2,2