WordPress.org

Plugin Directory

!This plugin hasn’t been updated in over 2 years. It may no longer be maintained or supported and may have compatibility issues when used with more recent versions of WordPress.

Comment E-Mail Verification

If a comment is held for moderation an email message is sent to the comment author with a link to verify the comment author's email address.

0.4.2

  • Fixes another bug that caused verification links generated with older versions of the plugin to malfunction with some setups
  • JavaScript sanity checks of SMTP options
  • Better sanitization of SMTP options in PHP (when JavaScript is turned off)
  • Verification codes not generated for trackbacks or pingbacks (thanks Joost de Valk for feedback and code contribution)

0.4.1

  • Fixed a bug that caused the verification link to malfunction with some setups

0.4

  • Note that E-mail address has not been verified in comment row actions, next to link 'Approve'
  • Option to hold comments for moderation even after commenters have verified their E-mail address
  • Splash screens editable

0.3

  • Send mail using SMTP (thanks Mark for testing and feedback)
  • German L10n

0.2

  • Administrators can now customize the sender mail address
  • 'Your comment is awaiting moderation.' hint altered – requires internationalized comment template (default template is perfect), can be customized
  • Optional splash screens when someone clicks on a verification link
  • Nicer error messages in case something goes wrong
  • Longer (safer) verification keys

0.1.2.1

  • Fixes a bug where mail was sent to authors of spam comments

0.1.2

  • Contextual help, with links to shortcodes and troubleshooting e-mail delivery
  • Code styling: wrapper class
  • WordPress core settings that affect the behaviour of this plugin can be altered on the plugin's options page directly
  • Much nicer default message template

0.1.1

  • Administrators can now customize the email message that is sent to comment authors
  • Blogname encoding issue fixed
  • Default message slightly reformatted
  • Short GPLv3 note in source code

0.1

  • initial public release

Requires: 2.9 or higher
Compatible up to: 3.8.15
Last Updated: 2 years ago
Active Installs: 1,000+

Ratings

5 out of 5 stars

Support

Got something to say? Need help?

Compatibility

+
=
Not enough data

0 people say it works.
0 people say it's broken.

0,1,0
100,2,2 100,1,1 100,1,1
100,1,1 100,1,1 100,1,1 100,1,1 100,1,1 100,1,1
0,2,0
100,1,1
100,1,1
100,1,1 100,1,1 100,2,2
100,1,1
100,1,1 100,1,1
100,1,1
67,3,2
100,1,1
100,2,2
100,1,1
100,1,1
0,1,0
50,2,1