WordPress.org

Plugin Directory

Client Dash

Creating a more intuitive admin interface for clients.

Requires: 3.8.0 or higher
Compatible up to: 4.1.0
Last Updated: 2014-12-11
Active Installs: 900+

Ratings

5 out of 5 stars

Support

1 of 5 support threads in the last two months have been resolved.

Got something to say? Need help?

Compatibility

+
=
Not enough data

1 person says it works.
0 people say it's broken.

100,1,1
100,1,1 100,2,2
100,1,1
0,1,0
100,1,1