WordPress.org

Plugin Directory

CKEditor for WordPress

This plugin replaces the default WordPress editor with CKEditor.

V4.5.3.3 - 04.09.2015

  • Removed the assets folder that is not needed to reduced the size of the package.

V4.5.3.2 - 04.09.2015

  • Fixed issue with calling is_plugin_active() outside admin pages that could cause fatal error.

V4.5.3.1 - 01.09.2015

  • Security update: fixed reflected XSS caused by improper sanitization in the "built-in (old)" file browser.

V4.5.3 - 24.08.2015

  • Fixed compatibility with WordPress 4.3.
  • Fixed skins auto-discovery.
  • Improved positioning of HTML and Visual tabs.
  • Updated CKEditor to 4.5.3.

V4.4.5 - 30.10.2014

  • Fixed preview/publish JavaScript errors in WordPress 4.x. Fixed by @vokiel.
  • Updated CKEditor to 4.4.5.

V4.4.4 - 18.09.2014

  • Fixed compatibility with WordPress 4.0.
  • Updated CKEditor to 4.4.4.
  • Added Advanced Content Filter setting in Advanced Settings.

V4.0.0.1 - 15.07.2014

  • Backported security patch from CKEditor 4.4.3.

V4.0 dev - 20.12.2012

  • Enabled bidi buttons

V4.0 - 19.12.2012

  • Updated CKEditor to version 4.0
  • Set the default skin to Moono
  • Modified the default toolbars
  • Increased the default height of editor for comments
  • Fixed image captions
  • Added protection against caching JavaScript files by the browser by appending CKEditor timestamp to js files
  • Fixed: CKEditor does not load when "external" plugin is enabled, but the required extension is not installed
  • Minor fixes in the old built-in file browser
  • Spellchecker plugins are now enabled in "Advanced Options"

V3.6.3 - 21.06.2012

V3.6.2.5 - 23.02.2012

V3.6.2.4 - 13.12.2011

  • Fixed problems with upgrade and working correctly in new WordPress 3.3 “Sonny”.
  • Fixed problem with loading CKEditor inside element with id 'content' which is not textarea.

V3.6.2.3 - 01.12.2011

V3.6.2.2 - 29.11.2011

V3.6.2.1 - 14.10.2011

V3.6.2 - 15.09.2011

  • Updated CKEditor to version 3.6.2
  • Fixed: CKEditor is in read only state after closing WordPress gallery popup (iframe)
  • Added support to "Custom fields template" plugin (http://wordpress.org/extend/plugins/custom-field-template/)
  • Refactor of functions used in WordPress gallery
  • Added index.html files to directories to protect against directory listing

V3.6.1.1 DEV - 22.08.2011

  • Fix to work when "After the Deadline" plugin is installed

V3.6.1 - 19.08.2011

  • Plugin naming conventions changed to match CKEditor version
  • Support for built-in WordPress file gallery added
  • Support for managing images via WordPress added
  • Shortcode support improved

V1.0.9 - 05.07.2011

  • Added compatibility for WordPress 3.2
  • Updated CKEditor to version 3.6.1

V1.0.8 - 10.05.2011

  • Updated CKEditor to version 3.6
  • Fixed error when calling undefinde getUserSetting function in ckeditor.utils.js

V1.0.7 - 08.04.2011

  • Updated CKEditor to version 3.5.3
  • Viper’s Video Quicktags – show buttons only from enabled options
  • Successfully tested with WordPress 3.1

V1.0.7 DEV - 17.03.2011

  • Viper’s Video Quicktags – show buttons only from enabled options
  • Successfully tested with WordPress 3.1

V1.0.6 - 17.02.2011

  • Updated CKEditor to version 3.5.2

V1.0.5 - 10.02.2011

  • Updated CKEditor to version 3.5.1

V1.0.4 - 05.11.2010

  • Updated CKEditor to version 3.5

V1.0.3 - 05.11.2010

  • Updated CKEditor to version 3.4.2
  • Corrected the default set of buttons that are available in comments

V1.0.2 - 21.09.2010

  • Updated CKEditor to version 3.4.1
  • Fixed qTranslate plugin compatibility
  • Added Bidi (LTR/RTL) buttons to the toolbar
  • Fixed: Reply to comment freezes unless source button is pressed

V1.0.1 - 14.06.2010

  • Fixed usage of PHP short tag causing parse error
  • Fixed "Read more" button
  • Fixed issues when working with the qTranslate extension (unable to save edited content)
  • Fixed issues with saving configuration files when using file editor

V1.0 - 11.06.2010

  • Updated CKEditor to version 3.3.1
  • Fixed issue with loading templates inside of CKEditor
  • Fixed compatibility with qTranslate
  • Added option to enable/disable SCAYT
  • Improved compatibility with WordPress 3.0
  • Fixed problem with MediaEmbed plugin (unknown variable ckeditorVariables)
  • Fixed built-in file browser

V1.0 Beta2 - 17.03.2010

  • Fixed compatibility with PHP4 and with disabled short tags

V1.0 Beta - 10.03.2010

  • Inital beta release

Requires: 3.2 or higher
Compatible up to: 4.3.5
Last Updated: 11 months ago
Active Installs: 90,000+

Ratings

3.4 out of 5 stars

Support

0 of 3 support threads in the last two months have been marked resolved.

Got something to say? Need help?

Compatibility

+
=
Not enough data

0 people say it works.
0 people say it's broken.

100,1,1
100,1,1
50,2,1 83,6,5
100,1,1 100,2,2
80,5,4 100,4,4 100,4,4
0,1,0
100,1,1 100,1,1
75,4,3 100,1,1
100,2,2 100,1,1
100,1,1 100,1,1 33,3,1 100,1,1 100,1,1
100,3,3 100,1,1
100,4,4
100,1,1
100,1,1 100,1,1 100,1,1
0,3,0 100,6,6 0,1,0
100,2,2 80,5,4 100,7,7 100,6,6 25,8,2 100,5,5 50,2,1 0,2,0
0,4,0 86,7,6
67,12,8 50,6,3
43,7,3 100,2,2
100,2,2 100,3,3
78,9,7
100,7,7 0,3,0
6,18,1 59,17,10
69,13,9
100,5,5
43,14,6
67,3,2
67,6,4
50,2,1
50,2,1
100,1,1
33,3,1 0,1,0
0,7,0 0,2,0
0,15,0 75,4,3 100,2,2
100,1,1
75,4,3
100,1,1
100,1,1
0,3,0 100,1,1 100,1,1 100,1,1
50,2,1
50,2,1
100,1,1
0,1,0
100,2,2