WordPress.org

Plugin Directory

Booking Calendar Contact Form

Booking Calendar Contact Form creates a booking form with a reservation calendar or a classic contact form, connected to a PayPal payment button.

1.0

  • First stable version released.
  • More configuration options added.

1.0.1

  • Interface modifications.
  • Fix for iCal format bug (the events weren't marked as all day events)
  • Compatible the latest WP and jQuery versions
  • Replaced YUI calendar with a jQuery calendar
  • Added support for weekly bookings
  • New language translations
  • Several bug fixes and new features for deposit payments
  • Fixed encoding issues at PayPal
  • Fixed bug in the address of the corner images for partial days mode.
  • CSS styles updates to avoid conflicts with theme styles
  • New options for customizing the emails
  • New feature for applying taxes

1.0.2

  • Compatible with the latest WordPress versions
  • New language translations
  • Fixed bugs in the language traslations
  • Interface updates
  • Fixed warning that appeared with PHP safe mode restrictions
  • Sanitized GET parameters used in queries
  • Fixed issue with the site home URL in WP with folders in non-default locations
  • Fixed bug in the url generated for the IPN under HTTPS connections

1.0.3

  • Fixed bug in the function that generates the url for the ipn notification.
  • Update for SQL issues - sanitized values.
  • Update to make the IPN work over SSL connections.
  • Fixed bug in email processing.
  • Updates to minimize conflicts with third party themes and plugins.

1.0.4

  • New feature to show/hide the calculated cost below the calendar
  • CSS update to avoid conflicts with the new WP default theme
  • Compatible with the latest WordPress 4.2.2 version

1.0.5

  • Fixed notice warning in not active feature.
  • Fixed bug in date calculation.
  • Fixed IPN address under SSL connections.
  • CSS update to fix the floating dialog height.
  • Fixed conflict of captcha image with zLib library
  • Fixed bug in the path calculated for the admin area.
  • Translations updated.
  • Improved security.
  • Compatible with the latest WordPress 4.2.3

Requires: 3.0.5 or higher
Compatible up to: 4.2.3
Last Updated: 2015-7-31
Active Installs: 2,000+

Ratings

3.6 out of 5 stars

Support

1 of 2 support threads in the last two months have been resolved.

Got something to say? Need help?

Compatibility

+
=
Not enough data

0 people say it works.
0 people say it's broken.

75,4,3
100,2,2
100,2,2
100,1,1
100,1,1
100,1,1
100,1,1
100,1,1
100,1,1
100,1,1
100,1,1
100,1,1
100,1,1
0,1,0