Plugin Directory

!This plugin hasn’t been updated in over 2 years. It may no longer be maintained or supported and may have compatibility issues when used with more recent versions of WordPress.

Big Mailer - SendGrid

Overwrites the native wp_mail function and uses sendgrid servers to send emails

Why do I get an error when I try to activate the plugin

BigMailer requires PHP version 5.3+

Requires: 3.0.1 or higher
Compatible up to: 3.6.1
Last Updated: 2 years ago
Active Installs: 100+


5 out of 5 stars


Got something to say? Need help?


Not enough data

0 people say it works.
0 people say it's broken.