Plugin Directory

!This plugin hasn’t been updated in over 2 years. It may no longer be maintained or supported and may have compatibility issues when used with more recent versions of WordPress.

BAFTA Guru widget

The BAFTA Guru WordPress Plugin and Widget allows you to easily feature Guru Video, Audio and Article content on your own website.

Requires: 3.0 or higher
Compatible up to: 3.3.2
Last Updated: 2012-2-22
Active Installs: Less than 10


0 out of 5 stars


Got something to say? Need help?


Not enough data

0 people say it works.
0 people say it's broken.