WordPress.org

Plugin Directory

Backdrop

Backdrop is an improved site background customizer allowing for all manner of fancy things.

2.1.2

  • Changes some of the session logic to support versions of PHP pre 5.4.
  • Fixed an order error regarding headers in the generator file.
  • Added a second check for adding the #backdrop-element to prevent odd cases where it would not load even though it should.

2.1.1

  • Fixed a bug that would cause the live preview not to update until you saved.
  • Added an option to not include the default backdrop element when in advanced mode.
  • Added links to the generated CSS and JS files when in advanced mode.
  • Added additional debug information to CSS and JS files when in advanced mode.
  • Plugin now checks to ensure sessions are available before opening one in order to prevent possible errors.
  • Fixed a possible CSS parse error if there was no background image used.

2.0.0

  • New from the ground up backdrop now supports the WP customizer.
  • Improvements to how the style-sheet and javascript files are generated.
  • Faster animations for smoother scrolling.
  • Added background color opacity option.

1.3.6

  • Confirmed plugin compatibility with WordPress 4.1

1.3.5

  • Confirmed plugin compatibility with WordPress 4.0

1.3.4

  • Added the ability to set the horizontal alignment to “stretch”, makign it exapnd to full width on some image background attachment types.
  • Fixed a JavasScript quirk that would cause the background to jump to where it should be on page reload.

1.2.3

  • Fixed a bug where the readme did not properly update for version 1.1.2
  • Added a new “Miscellaneous” section to the settings page.
  • Added a proper screenshot to replace the one that went missing at some point.

1.1.2

  • Added options to control horizontal position when using parallax.

1.0.2

  • Fixed an issue that would cause the CSS and JS files generated to be replaced with the default blank ones when the plugin was updated.

1.0.1

  • Fixed a broken image link on settings page.
  • Removed an unused variable from the default settings and it's appropriate settings page option.

1.0.0

  • Initial Release

Requires: 4.0 or higher
Compatible up to: 4.1.1
Last Updated: 2015-4-11
Active Installs: 100+

Ratings

5 out of 5 stars

Support

Got something to say? Need help?

Compatibility

+
=
Not enough data

0 people say it works.
0 people say it's broken.

100,1,1
100,1,1