Plugin Directory

Average WYSIWYG Helper

Highlights prominent HTML elements in the WYSIWYG editor, to help Editors see what they're editing. Sort of a WYSIWYM (the M is for mean).

Notice Average is changing its name to AddFunc (good thing). Therefore, this plugin has been improved and republished as AddFunc WYSIWYG Helper. In the "AddFunc version", the WYSIWYG Helper settings are a user preference rather than a universal preference that can only be managed by an Administrator. The "AddFunc version" is compatible with the "Average version," so installation and activation is risk-free. Just deactivate the old one, install/activate the new one, turn it on in your user profile preferences and you're done. Switching to the "AddFunc version" is optional. The "Average version" will remain available with minimal support until it becomes a burden for AddFunc (probably for many years to come, as of 2015). Any new features will only be added to the "AddFunc version," so it is of course the recommended version (at least moving forward). Thanks!

Average WYSIWYG Helper is a lightweight plugin that uses CSS to highlight prominent HTML elements in the default WYSIWYG editor (Tiny MCE), to help Editors see what they're editing. This in effect creates a sort of combination WYSIWYG/WYSIWYM (What You See Is What You Mean) combination. With the WYSIWYM option turned on, the following elements are highlighted with a colored border and label:

  • p
  • div
  • ol
  • ul
  • li
  • span*

*Span are highlighted without a label, but even more prominently, so they are easy to spot. This can help Editors keep the code clean, as they can see where they need to remove unwanted styling using the style eraser button.

Your theme can still apply an editor-style.css stylesheet. In most cases, the WYSIWYG will still reflect how the content will look on the front end of the live website.

Average WYSIWYG Helper also provides an option to cancel out certain default styles in the WYSIWYG, such as the caption box/border.

Note: It is suggested that Editor's use a browser that supports CSS3 for best results.

Custom support tickets are available

See Other Notes tab for details.

Requires: 3.0.1 or higher
Compatible up to: 4.0.8
Last Updated: 9 months ago
Active Installs: 200+


5 out of 5 stars


Got something to say? Need help?


Not enough data

0 people say it works.
0 people say it's broken.