WordPress.org

Plugin Directory

Arconix Testimonials

Easily showcase what your customers or users are saying about you or your business.

Requires: 3.8 or higher
Compatible up to: 4.0.1
Last Updated: 2014-9-5
Active Installs: 100+

Ratings

5 out of 5 stars

Support

1 of 1 support threads in the last two months have been resolved.

Got something to say? Need help?

Compatibility

+
=
Not enough data

0 people say it works.
0 people say it's broken.

50,2,1
100,1,1