WordPress.org

Plugin Directory

Test out the new Plugin Directory and let us know what you think.

Apocalypse Meow

A simple, light-weight collection of tools to help protect wp-admin, including password strength requirements and brute-force log-in prevention.

20.1.8

  • [New] Ability to control access to WP-REST requests.
  • [Fix] Extend user enumeration protection to API requests.

20.1.7

  • [Fix] pass-by-reference notice.

20.1.6

  • [Fix] IPv6 whitelist bug.

20.1.5

  • [New] Option to mitigate phishing attempts with rel=noopener.
  • [New] Additional common password checks.
  • [Misc] Admin area improvements.

20.1.4

  • [Change] Show number of remaining attempts after login failure.
  • [Fix] Failed login attempts not always expiring.

20.1.3

  • [Fix] Layering bug that could make the Settings > Save button unclickable.

20.1.2

  • [Fix] Address PHP notice.

20.1.1

  • [New] The plugin has been completely rewritten from the ground up to provide a cleaner interface, faster performance, and additional features.

2.2.0

  • [New] Option to disable XML-RPC.
  • [New] Option to remove adjacent post meta tags.
  • [New] Support plugin configuration via wp-config.php.

2.1.2

  • [Change] Common password list has been expanded to around 500 entries.

2.1.1

  • [Change] Tweak nonce error display.

2.1.0

  • [New] Option to add Nonce field to the login form.
  • [New] Email alerts after login from new location.

2.0.1

  • [Fix] More robust username retrieval.

2.0.0

  • [Fix] Forgot password reset enforces password strength rules.
  • [New] Don't allow Top 25 Most Common passwords ever.
  • [Change] Move database cleanup to WP Cron.
  • [Misc] Code clean-up.

1.7.0

  • [New] Ability to clear unclaimed pardons.

1.6.0

  • [New] In honor of Heartbleed, there is now a tool for resetting all user passwords en masse.

1.5.0

  • [New] Allow alternate $_SERVER variables for proxy installations (thanks jjfalling).
  • [Misc] Code clean-up.

1.4.5

  • [New] Warn administrators on settings page of potential proxy/intranet-type issues.
  • [Fix] Only show .htaccess options on Apache servers.
  • [Change] Use wp_die() for Apocalypse screen.
  • [Change] Database maintenance on by default.

1.4.4

  • [Misc] File clean-up.

1.4.3

  • [Fix] Ensure variables are declared at activation.

1.4.2

  • [Fix] Replace deprecated $wpdb->escape() with esc_sql().

1.4.1

  • [Fix] Replaced a couple functions that are deprecated as of PHP 5.5.0.

1.4.0

  • [New] Log-in jail page to view currently banned IPs.
  • [New] Ability to temporarily pardon a banned IP.
  • [Fix] Log-in history now displayed in viewer's timezone.

1.3.6

  • [Fix] Call-time pass-by-reference warning/error in PHP 5.3+.

1.3.5

  • [Change] Fail window unit converted minutes.
  • [Misc] More efficient logging of Apocalypse triggers.
  • [Misc] Simplified Apocalypse page options.
  • [Fix] Database upgrade procedure skipped.

1.3.4

  • [Change] Lowered data retention minimum to 10 days.
  • [New] Option to manually clear data.
  • [Fix] Uninstallation now removes all plugin data/settings.
  • [New] Option to disable theme/plugin editor.
  • [Change] Prevent installation on WPMU blogs.
  • [Fix] Use $_SERVER instead of getenv() as it is more compatible across server environments.
  • [Fix] Minor bug fixes.

1.3.3

  • [New] Log-in statistics.
  • [Change] Storing UA string with log-in attempt is now optional (default disabled).
  • [Misc] Log-in protection settings now hidden if log-in protection is disabled.
  • [Misc] Database maintenance settings now hidden if maintenance is disabled.

1.3.2

  • [Misc] Use existing WP CSS for log-in history table.
  • [Change] Set 403 status header when displaying Apocalypse screen.

1.3.1

  • [Misc] Compatibility with WP 3.5.
  • [Misc] All queries now run through $wpdb.

1.3.0

  • [New] Ability to rename the default WordPress user to something less .predictable.
  • [Fix] Minor bug fixes.

1.2.0

  • [New] Ability to disable the direct execution of PHP scripts in wp-content/.
  • [Change] Re-organized the settings page.

1.1.0

  • [New] Customizeable page title and content for the Apocalypse page;
  • [New] Apocalypse page display logging.
  • [Fix] Improved timestamp handling.
  • [Change] Un-embedded kitten graphic for improved support with older browsers.

1.0.0

  • [New] Apocalypse Meow is born!

Requires: 4.4 or higher
Compatible up to: 4.7.3
Last Updated: 2 months ago
Active Installs: 2,000+

Ratings

5 out of 5 stars

Support

Got something to say? Need help?

Compatibility

+
=
Not enough data

0 people say it works.
0 people say it's broken.

100,1,1 100,1,1 100,2,2 100,2,2 100,1,1
100,2,2 100,1,1 100,1,1 100,1,1 100,1,1
100,1,1 100,2,2 100,1,1 100,3,3
100,1,1
100,1,1
100,1,1
100,1,1
100,1,1
100,1,1
100,1,1
100,1,1
100,2,2