Plugin Directory

!This plugin hasn’t been updated in over 2 years. It may no longer be maintained or supported and may have compatibility issues when used with more recent versions of WordPress.

Amazing WP e-Commerce

Enable some of the WP e-Commerce disabled features and simplify your development.

Active Versions

Downloads Per Day

Downloads history

Today 1
Yesterday 0
Last Week 1
All Time 1,981

Requires: 3.0.1 or higher
Compatible up to: 3.5.2
Last Updated: 2013-3-12
Active Installs: 80+


5 out of 5 stars


Got something to say? Need help?


Not enough data

0 people say it works.
0 people say it's broken.

100,1,1 100,1,1