This plugin hasn’t been updated in over 2 years. It may no longer be maintained or supported and may have compatibility issues when used with more recent versions of WordPress.

Advanced Custom Fields – Required Field add-on

Description

This Add-on has been Deprecated

The functionality provided by this add-on is now included in Advanced Custom Fields.
This plugin will no longer be maintained and it is recommended that everyone discontinue its use.

This is an add-on for the Advanced Custom Fields
WordPress plugin and will not provide any functionality to WordPress unless Advanced Custom Fields is installed
and activated.

The required field provides the ability to create fields that must be filled out before a post can be published.
Required field is a wrapper for other field types, meaning that you can use this field with any other field in
Advanced Custom Fields to make it required. Some complex field types may not function properly if marked as
required (required field may think it has content when it really does not).

Source Repository on GitHub

https://github.com/GCX/acf-required-field

Bugs or Suggestions

https://github.com/GCX/acf-required-field/issues

Screenshots

  • Required field in use on the Add Page admin screen.
  • New Page published with a required field missing.
  • Required field shown making a Text field required.

FAQ

I’ve activated the plugin, but nothing happens!

Make sure you have Advanced Custom Fields installed and
activated. This is not a standalone plugin for WordPress, it only adds additional functionality to Advanced Custom Fields.

Changelog

1.0

  • Initial Release

Contributors & Developers

This is open source software. The following people have contributed to this plugin.

Contributors

Browse the code