WordPress.org

Plugin Directory

Google AdSense Click-Fraud Monitoring Plugin

Google AdSense Plugin for Google AdSense and other PPC vendors. Prevents to be banned due to malicious clicks on your ads. Increases CPC and your reve

Requires: 3.1+ or higher
Compatible up to: 4.2.1
Last Updated: 2015-4-24
Active Installs: 10,000+

Ratings

4.6 out of 5 stars

Support

3 of 7 support threads in the last two months have been resolved.

Got something to say? Need help?

Compatibility

+
=
Not enough data

0 people say it works.
0 people say it's broken.

100,1,1
100,1,1 100,1,1 100,1,1
100,1,1 100,1,1
100,1,1 100,1,1
100,2,2 100,1,1 100,1,1
100,1,1 100,1,1 100,1,1 100,1,1 100,1,1 100,1,1
100,1,1
100,1,1
100,2,2 100,1,1 100,1,1
100,1,1
100,1,1
0,1,0
100,1,1
100,1,1
100,1,1