This plugin hasn’t been tested with the latest 3 major releases of WordPress. It may no longer be maintained or supported and may have compatibility issues when used with more recent versions of WordPress.

Accessibility (a11y) Speech Synthesis

Description

Make your browser speak when wp.a11y.speak() is called. Requires a browser that supports speechSynthesis (which all currently do except for IE11).

This is useful for development to simulate what a user experiences when using a screen reader.

Contributors & Developers

“Accessibility (a11y) Speech Synthesis” is open source software. The following people have contributed to this plugin.

Contributors

Changelog

0.2.0

  • Fixed: Pass ariaLive param to original wp.a11y.speak().
  • Fixed: Prevent reading markup in message.
  • Fixed: Stop speaking any previous utterance before speaking the next one to emulate clear().
  • Updated: Refactor JS script registration to better swap out and wrap core’s wp-a11y script.
  • Updated: Simplified plugin to the bare minimum required PHP.

0.1.0

Initial release