WordPress.org

Ideas

Use PDO

  1. Daisuke Takahashi
    Inactive

    For non-MySQL user, WPDB class should use PDO!

    Posted: 3 years ago #
  2. Ipstenu (Mika Epstein)
    Administrator

    Actually we're using both :)

    https://core.trac.wordpress.org/ticket/21663

    Posted: 3 years ago #
  3. It seems latest wp-db.php is using only MySQLi...

    Posted: 3 years ago #
  4. Ipstenu (Mika Epstein)
    Administrator

    Read the whole ticket. This is the first step in a long road of retaining backwards compatibility, not breaking plugins and themes, and moving to the future where php 5.5 will be needed for much of this.

    Posted: 3 years ago #
  5. Saumya Majumder
    Member

    12345

    I would love to see this happen. That ticket is quite old and we are now in PHP v7.1 still wordpress doesn't support PDO. It's Sad.

    Posted: 11 months ago #
  6. hack8hide
    Inactive

    Are there updates on wordpress about using PDO?

    There's PDO (lite) plugin, let's test it.

    Posted: 3 months ago #

RSS feed for this topic

Reply

You must log in to post.

  • Rating

    12345
    4 Votes
  • Status

    Good idea! We're working on it