WordPress.org

Ideas

Easy Updating of WordPress

  1. Stuarts
    Member

    Nice in theory.

    In practice if you have anything but a bog standard install, then at least a few of the plugins will break.

    As plugins often affect the core look of a blog. In practice you could NEVER use this feature.

    Even if it scrolled through and told you which plugins needed updating. What is the point?

    If just one plugin was incompatible then the whole thing breaks.

    Personally, I hate this auto update feature in firefox for this very reason. Half my plugins break. And for what? Some upgrade that makes very little difference to the look or funtionning of this blog?

    Posted: 11 years ago #
  2. adubeezi
    Member

    12345

    You could just download the Automatic Update plugin tho.

    But it would have been nice if this was inegrated in one of the next releases, so we didnt have to hazzle with all the plugins..

    Posted: 11 years ago #
  3. Binh WPO
    Inactive

    12345

    Certainly. This function should be in the core. If not, it must be developed by the WordPress team as a plugin.

    We are suffering from manual update, especially my case I have to manage many blogs and each time has to deactivate the plugins, then reactivate them, also have to backup DB....

    Consider now it's just for 3 blogs on Apmart.com Discount Shopping which shall extends to hundreds.
    + 5 blogs on my personal site.
    + My girlfriend's blogs.

    ALL TOO HASSLE!!!

    I know it will be solved. So thanks in advance.

    Posted: 11 years ago #
  4. ws.rudi
    Member

    That's Good Idea Man!

    Posted: 11 years ago #
  5. Julian Moreno
    Member

    Another vote for the one-click upgrade.

    Posted: 11 years ago #
  6. Alex Mills
    Inactive

    12345

    FYI: This is already in the core of WordPress 2.7 and is working great (mostly). :)

    Posted: 11 years ago #
  7. Success Point
    Member

    I upgraded to version 2.6.3 with no problem. If you are having upgrade issues, it's probably because of a plug-in.

    The idea of a 1-click upgrade makes me wonder about security issues.

    I'm not sure if what Viper007 said above is true, that it's in WordPress 2.7.

    If it is, I hope they have the bugs worked out.

    Posted: 11 years ago #
  8. copperblade
    Inactive

    12345

    It's already super-easy if you just use the tags in subversion. So my vote is to give WP some kind of svn functionality (if possible) that will allow upgrading using the infrastructure that's already available.

    Posted: 11 years ago #
  9. basgras
    Member

    12345

    I currently use Simple Scripts and before that Fantastico, and they're really useful for updating your WordPress. It's done in a jiffy.

    But it would be better if it was just directly from the Dashboard.

    Posted: 11 years ago #
  10. It is in 2.7 Down in the admin footer there is "You are using a development version (2.7-beta1-9535). Cool! Please stay updated." And the Stay Updated is a link to the newest nightly build with the auto installer. I might be wrong but I believe you must be an admin.

    Posted: 11 years ago #

RSS feed for this topic

Reply »

You must log in to post.