Deprecate get_sidebar and "Sidebar"
Can we deprecate get_sidebar() in favor of something more semantic? Like, get_support, get_supplement, or anything? Theme developers are now using get_sidebar for far more than just a "sidebar" and it's going to become ridiculous.
At the very least it would be nice to drop the use of the word "Sidebar" in the admin area. Theme developers should be allowed to decide what their "sidebars" actually are.
I understand what you're saying here, but I don't think the proposed deprecation would help anyone out. If all you're doing is changing the name, I don't think it is worth it.
I think it's a great idea. I'm not big on naming sidebar "sidebar." I usually have a primary content and secondary content area. Sometimes my sidebar is my Navbar. I want to be able to name it anything I want to name it when making a new theme.
Ian, I'm right there with you. Quite frankly, I was a bit surprised to see the added functionality for get_sidebar(), which is a neat function but has the word "sidebar" in it.
Many are still thinking in terms of a traditional blog. I'd like to see us step outside of that a bit.
I'd like to see this implemented for any file, such as something like this:
I think it just makes sense to have a new name for it. Right now,
get_sidebar still makes sense to a lot of people. Will it still have the same meaning a year from now? That's the real question. The only way for us to answer it would be to continue stretching the boundaries of WordPress.
Not really a big deal IMHO. Theme authors already know that get_header(), get_footer() or get_sidebar() just include an arbitrary filename.
Moreover, in about 90% of themes get_sidebar() actually brings a real sidebar. Theme where get_sidebar() is a "semantic" heresy are far from being common.
I don't get why changing the name would make things easier.
I'm not sure that it's entirely about making things easier. I think it's about making sense.
I agree with the "making sense" comment.
It does not necessarily "neeeeeed" to be changed but it probably should be. This change is certainly in line with the WordPress usability statement about aesthetics, and ease of use etc...
Let's do it...
All WordPress parts(blocks) as widgets sidebar
I think it's a great idea. I know for the longest, I always saw the sidebar, as well, the "side"bar simply because of the name. It wasn't until I had some creative thought that I realized that the sidebar wasn't limited to the "side." I think it would new developers, such as myself, to come to that realization much sooner than I did.
Agreed. Makes much more sense as get_block() or suchlike.
RSS feed for this topic
This topic has been closed to new replies.