WordPress.org

Ideas

Check prerequisites at the install process

  1. eitanc
    Member

    Guys.... I just tried to install WP, 5.2.3, after I didn't do so for a long time.

    All went fine until the first login page. Crypting PHP errors. Only after a long search I realized that my shared hosting cpanel PHP version was using version 5.4 as the default (and they support only up to PHP 7.1, while WP 5.2.3 asks for at least PHP 7.3). So, I cannot install it at all.

    Please, assist us to avoid such issues - in the install process check all needed prerequisites and if something is missing or wrong - stop us there, let us know nicely what is wrong and how to fix this and don't move forward, for us to fall into a deep, black, hole... thanks!

    Posted: 1 month ago #
  2. Actually you can use WP on PHP 7.1

    Re-read https://wordpress.org/about/requirements/

    If you are in a legacy environment where you only have older PHP or MySQL versions, WordPress also works with PHP 5.6.20+ and MySQL 5.0+, but these versions have reached official End Of Life and as such may expose your site to security vulnerabilities.

    5.4 shouldn't even be on any responsible host's servers. It hasn't been supported since 2015.

    Posted: 1 month ago #

RSS feed for this topic

Reply

You must log in to post.

  • Rating

    12345
    0 Votes
  • Status

    This idea is under consideration

No tags yet.