WordPress.org

Ready to get started?Download WordPress

Plugin Reviews

Wordfence Security

Wordfence Security is a free enterprise class security and performance plugin that makes your site up to 50 times faster and more secure.

1234142

1419 reviews
Average Rating
4 stars
4.9 out of 5 stars
5 stars
The BEST!!
By , for WP 3.9.1

I've researched security plugins more than I care to admit before settling on WordFence. I really like this program and it just plain works! Getting the notifications I find invaluable!

4 stars
Very useful, works well
By , for WP 3.9.1

In my opinion this is an essential plugin for any WP site.

5 stars
Top!
By , for WP 3.9.1

Works well and easy to use!
Congratulations!

5 stars
Absolute Must
By , for WP 3.9.1

Absolute must if you are managing several WP sites.

5 stars
excellent
By , for WP 3.9.1

Wordfence works great out of the box and stays up to date on the latest wp vulnerabilities.

5 stars
My New Most Favorite Plugin EVER
By ,

My hosting service installed this for me, in fact, installed it on all of their clients sites, because it's so darn good. When I get the email about the suspicious email about someone trying to log in -- I check out the IP address for kicks and grins. So far it's been the Phillipines and Russia. THANK YOU WORD FENCE!!!!!

5 stars
Excellent eMail support
By , for WP 3.9.1

Very timely eMails on Plug-In vulnerabilities and fixes. Been using free version for over a year on many sites.

5 stars
so far so good
By ,

Very impressed with the alerts I have been receiving. This morning I received an alert about a potential threat from one of my plugins and I was able to update it right away.

5 stars
Has already protected my website
By , for WP 3.9.1

I installed this plugin on all of my WordPress websites after one of them was hacked. Almost immediately, I could see it protecting my websites from brute-force attacks. Easy to configure and very powerful. Recommended!

5 stars
Excellent plugin!
By , for WP 3.9.1

I especially like the blocking of unauthorized users and immediate notification of plugins with serious vulnerabilities.

You must log in to submit a review. You can also log in or register using the form near the top of this page.