WordPress.org

Ready to get started?Download WordPress

Plugin Reviews

NextGEN Gallery

The most popular WordPress gallery plugin and one of the most popular plugins of all time with over 10 million downloads.

145663

622 reviews
Average Rating
3 stars
3.9 out of 5 stars
1 star
doesn't work like before
By ,

That was the best gallery plugin. But the new version is buggy and doesn't work. If I try to put the old version also it doesn't work now.

1 star
Didn't care for it
By , for WP 3.9.1

Caused my site to load very slowly even though I wasn't using the plugin. It also seems to mess up other areas of the site not related to the plugin.

Doesn't play well with other plugins.

1 star
Completely ruined this plugin
By , for WP 3.9.1

That they are going out of their way to prevent you from removing all their crappy styles and scripts has ruined this once great plugin.

5 stars
Great Plugin ..
By , for WP 3.9.1

Great Plugin ..

5 stars
I like NextGEN Gallery
By , for WP 3.7

I like this plugin, it's easy to use and have good functionality.

4 stars
Works, but has some bugs
By , for WP 3.9.1

Thank you for the good plugin.

The import of a whole directory was very valuable for me while importing content from an old site. However if the directory contains more than 60-70 images, the imports can't handle them all and freezes. Then I must go to the gallery's edit page and use the "Scan folder for new images" button to import the rest of them. Also when I use the Import directory button multiple times, after 20-25 imported galleries I receive a server error, which says that the cookies request is too long and I can't open any page anymore, until I delete the cookies for this site.

Another issue is that I have a JS error on a post page, which doesn't contain a gallery:
TypeError: b.fancybox.init is not a function
http://example.com/site-content/plugins/nextgen-gallery/products/photocrati_nextgen/modules/lightbox/static/fancybox/jquery.fancybox-1.3.4.pack.js?ver=3.9.1
Line 46

Please let me know how can the last issue be solved, because I wouldn't like to have JS errors on my site. I use the Hueman theme.

Edit: The theme recommends the "Light - Responsive LightBox" plugin (http://captaintheme.com/plugins/light/) and when I deactivate it, the JS error disappears. Is it it possible to use both plugins without such conflicts?

Thanks you in advance.

5 stars
worked very well
By , for WP 3.9.1

Das Plugin bietet viele Möglichkeiten. Mehr als man erwarten würde und es funktioniert einwandfrei.
Thank you for this famouse plugin!

1 star
Can't upgrade to 2.anything
By , for WP 3.9.1

Been running the last version before the upgrade to 2.0 but even the version before has ceased to allow uploads claiming my browsers (yes all of them) doesn't posses flash, silverlight, html 4 or 5. Tried again to install the latest update 2.6x and it refuses to show any of the image galleries now but the backend seems to run fine, fat lot of good that does me.
This used to be the go-to plugin but it's just causing me nothing but pain. I've tried everything I know to track the problem since July 2013 but I finally gave up today. I'm going to have to rebuild dozens of galleries for free in another program just to replace this plugin. What a waste of time and energy.

4 stars
used it once. worked great
By , for WP 3.9.1

used it for a straight forward image gallery requirement..worked like a charm!

4 stars
lots of options, shortcodes examples would be nice
By ,

this is a great plugin.
I found the shortcode examples hard to follow

You must log in to submit a review. You can also log in or register using the form near the top of this page.