WordPress.org

Ready to get started?Download WordPress

Plugin Reviews

Easing Slider "Lite"

Easing Slider "Lite" is an easy to use slider plugin. Simple and lightweight, built with native WordPress functionality.

52 reviews
Average Rating
4 stars
4.4 out of 5 stars
You are currently viewing the reviews that provided a rating of 5 stars. Click here to see all reviews.
5 stars
Works Awesome!
By ,

So hard to find a simple slider! This works great, loads fast, and is easy for clients to add images without too many settings. Thanks!

5 stars
Awesome Plugin
By , for WP 3.9.1

Awesome Plugin

5 stars
Working!
By , for WP 3.9

Original review: The Pagination Icons are vertical and couldn't fix it!

PS: The plugin is working properly after moving the shortcode to index.php

5 stars
Works
By , for WP 3.8.3

Simple and lightweight - all I need for my website.

5 stars
Super Easy To Use
By , for WP 3.8.2

I just installed this responsive slider plugin in one of my client's WordPress and it is super easy to use.

All you need is to add images and make sure the dimensions tally the sizes of your images and that's it. You can adjust the speed of transition, to fade or slide, to show or hide navigations and duration of slide transition.

You can see it in action here - http://akmaliasarman.com/

5 stars
Great little plugin
By ,

Have used this on a few sites now and I think it works well.

Nice and simple easy to use plugin that doesn't get in the way with too many styles, etc...

5 stars
Great slide show!
By , for WP 3.8.1

Easy to install, easy to learn. Smooth transition between images.

5 stars
Nice slider
By , for WP 3.9.1

This plugin works very well in the header of twenty twelve. See it on my spiritual blog: http://www.column-razenberg.nl

Willem

5 stars
Incredible Plugin
By , for WP 3.8.1

It's just a great plugin hands down.

5 stars
Errors in the Galaxy Tab
By , for WP 3.8.1

I'm sorry in Google Translate.
I'm using 3.8.1, Twenty Fourteen, but it is an error to try to look at the Galaxy Tab.
And the following message will appear.
------
event.returnValue is deprecated. Please use the standard event.preventDefault() instead.
jquery.js?ver=1.10.2:4 
------
How will the error to be a Lite?
It is planned to buy Pro, the operation or will no problem?

You must log in to submit a review. You can also log in or register using the form near the top of this page.