WordPress.org

Ready to get started?Download WordPress

Plugin Reviews

Kaltura All-in-One Video Plugin for WordPress

Easily add full video capabilities to your blog.

5 reviews
Average Rating
3 stars
3.3 out of 5 stars
You are currently viewing the reviews that provided a rating of 1 star. Click here to see all reviews.
1 star
Waste of time!
By , for WP 3.5.1

Don't bother with this plugin, outdated with to many issues.

I read other neg comments but still gave it a try (thought I could code the bugs out of it) but instead I just wasted 1 hour of my life.

This plugin is abandoned... and you should abandonee this page!

1 star
Not working
By , for WP 3.5

Not working, make a "Fatal error" on the plugin activation.

1 star
Abandonware
By , for WP 3.5

The last update to this plugin was June 11 2012. Before that, it was Dec 29th 2011. It should be considered abandonware due to the lack of updates.

The lack of updates has resulted in an unstable plugin. The plugin uses deprecated functions such as get_settings (deprecated since version 2.1!). And contains other oddities that go against best practices such as require_once('../../../wp-load.php');

Kaltura is a large company and calls its product an "Open Source Online Video Platform". It is really unfortunately that they seem uninterested in maintaining this plugin.

1 star
Breaks multisite - do not use
By , for WP 3.5

[Please stop posting in uppercase. It's the electronic equivalent of shouting and is considered quite rude. Post title de-capped.]

I'm not sure how the developers (Kaltura) expect to charge for a service that is broken and was reported as broken six months ago.

The plugin touts repeatedly that it works with WordPress Multisite - it does not. It breaks the Network admin - complete blank of every part of the Network administration section. The only way to get back into it is to disable the plugin or FTP in and delete it.

1 star
works only for admin?!!!
By , for WP 3.5

I have installed this plugin on my 3.3.2 version WordPress site. I can use it as admin and be able to see the icon on above the tool bar. But when I login as contributor I don't see the icon.

Why is that?

You must log in to submit a review. You can also log in or register using the form near the top of this page.