WordPress.org

Ready to get started?Download WordPress

Forums

vanilla-pdf-embed
[resolved] Zoom or magnify setting? (9 posts)

  1. LesTexas60
    Member
    Posted 6 months ago #

    Just loaded the plugin and it works great. I went to the edit and see the width & height setting but don't see a Zoom option. I tried to add a Zoom to the code but it didn't seem to affect the open. My PDF's are opening at 77% and I would like a default of 100% so the PDF is easily readable. I just used the shortcode URL load. I also tried adding #zoom=100% but no effect their either.
    Any suggestions would be appreciated.

    https://wordpress.org/plugins/vanilla-pdf-embed/

  2. Mike Doherty
    Member
    Plugin Author

    Posted 6 months ago #

    There is no zoom option, so that won't have any effect.

    PDFs should be scaled to fit in the embedded frame horizontally in most browsers (Chrome doesn't support that).

  3. LesTexas60
    Member
    Posted 6 months ago #

    Hi Mike, I have found multiple articles and even Adobe docs talking about Zoom or Scale settings for URL called PDF files. The problem is I can't seem to make them work. I don't know if it's a matter of format or what. When you say the frame should be horizontal, do you mean the frame width should match the PDF width, so you don't have to scroll horizontally?

    I am thinking this may also be a Theme type setting that is stopping me. I have run into this before.
    Thanks for the comments.

  4. Mike Doherty
    Member
    Plugin Author

    Posted 6 months ago #

    Yes, because the plugin doesn't provide any way for you to set the zoom/scaling. It is currently hardcoded to fit the PDF horizontally in the embed frame. The full width of the PDF should fit inside the frame horizontally. This isn't supported in Chrome, however.

    Again, there is no way to configure it differently. I'd happily accept patches to change that, however.

  5. LesTexas60
    Member
    Posted 6 months ago #

    Mike, Funny, I just tried viewing the site in Chrome and the PDF shows in 100% rather than 76 in the other browsers. To bad the frame width is to narrow to see it. I bumped the width up to 1200 but no effect.

    Well, I just saw that you are the author,, great plugin Mike..

  6. LesTexas60
    Member
    Posted 6 months ago #

    Mike, just a note. I looked at the site with Firebug and I found the plugin code. It has a width and height. I was surprised to see it wasn't what I had set it to in the Edit option of the plug in. When I increased the width, through Firebug the PDF grew in size and magnification. Is there something I may have done incorrectly in the Plug in Edit option that it didn't transfer to the Embed code?
    I can do screen print if it would help.
    The page is http://lowellinchamber.com/?p=191

    Thanks so much.

  7. LesTexas60
    Member
    Posted 6 months ago #

    Mike, and anyone else..An Update
    Raw Html Snipits ended up being part of the solution.
    It seems so many times we need to make modifications to the code on our pages but when we add the code to the "Text" mode we are then restricted from ever using the Visual mode for that page. This is true because the Visual mode strips out code it doesn't understand.
    In this posting, I was able to open Firebug and location the Frame size for my PDF. I then modified the Width parameter in Firebug and saw, that the modification worked. I then copied that code to a Snipit which created a Shortcode that could safely be put in the "Text" area of the page. This solution is a great work around for people who are having issues with other plugins that don't wrap questionable code.
    Thanks for the help and the plugin Mike.

  8. Mike Doherty
    Member
    Plugin Author

    Posted 6 months ago #

    There's no need to use raw HTML snippets for this. You can specify the frame width with the shortcode:
    [pdf width="1px"]PDF URL[/pdf]

  9. LesTexas60
    Member
    Posted 6 months ago #

    Thanks for the shortcut Mike..

Reply

You must log in to post.

About this Plugin

About this Topic

Tags

No tags yet.