WordPress.org

Ready to get started?Download WordPress

Forums

Zone Alarm Obstructs Login (19 posts)

  1. snorris
    Member
    Posted 8 years ago #

    I'm running Word Press locally on a test server.
    I can not login to the Word Press admin panel unless I turn Zone Alarm Pro off.

    I do not see Word Press in Zone Alarm's program control panel so I can not tell Zone Alarm to allow Word Press into the "Trusted Zone".

    How do I configure Zone Alarm Pro to allow me to log into Word Press?

    Thanks

  2. Mark (podz)
    Support Maven
    Posted 8 years ago #

    Try allowing http://localhost as a trusted site ?

  3. vkaryl
    Member
    Posted 8 years ago #

    Also, you should be able to add WordPress through ZA's program control panel, there should be an "Add" button next to the Entry Detail pane at the bottom of the screen.

  4. snorris
    Member
    Posted 8 years ago #

    re: getting Zone Alarm to recognize Word Press.
    I added http://localhost to the trusted zone.
    Still can not login to Word Press.

    To add an application to ZA's program control panel, it appears that ZA is looking for a .exe which WP doesn't have.

    Any other suggestions?

    Thanks

    Thanks

  5. vkaryl
    Member
    Posted 8 years ago #

    Boy, that's an odd one.... I have ZA, and I have a local test server, and I've never had the problem. Does this occur if you use a different browser?

  6. snorris
    Member
    Posted 8 years ago #

    same problem with firefox and explorer

  7. vkaryl
    Member
    Posted 8 years ago #

    Okay.... what happens if in ZA you give it the server executable? For instance, if you're using apache give it Apache.exe....

  8. snorris
    Member
    Posted 8 years ago #

    I added Apache and gave it "Super" trust level in ZA.
    Still can not log in without shutting ZA down.

  9. vkaryl
    Member
    Posted 8 years ago #

    Hmm. That's - just weird. Have you tried ZA's tech support?

  10. snorris
    Member
    Posted 8 years ago #

    By the way ... I am testing a phpBB forum on the same Apache/PHP/mySQL test server and do not have problems logging into the admin panel. This is why I am baffled as to why I cannot login to Word Press Admin panel with ZA turned on.

  11. snorris
    Member
    Posted 8 years ago #

    I'll give ZA tech support a try.
    If they offer it.
    I did not stop to consider this.
    Thanks

  12. vkaryl
    Member
    Posted 8 years ago #

    Let us know how it goes, okay?

  13. Steve
    Member
    Posted 8 years ago #

    I had a similar problem. I'm not sure which version of ZA you're using (firewall, spyware, whole suite?) but I am using the Internet Security Suite and this worked for me...

    In the Privacy section (not Program Control) I went to the Site List tab, looked for my URL (www.stevhill.com) and changed the setting to Allow Private Headers.

    Not sure if this will help you as I am running my site live on the web, not on localhost, but maybe you can adapt the answer ...

    Good luck.

  14. snorris
    Member
    Posted 8 years ago #

    I'm using Zone Alarm Pro.
    I tried to adopt your solution but am still not able to logon to my admin panel. I suspect this has something to do with a cookie that is not being placed or read properly. I posted to the Zone Alarm forum but they have not been able to help me either. I'm suprised that I can not get help with this. After all surely I am not the only person to use the combination of Zone Alarm and Word Press on a test server? Am I?

  15. vkaryl
    Member
    Posted 8 years ago #

    Well, I do as well, and haven't ever had a problem. Though I note that mine's the free version, not the pro one.... and it's JUST the firewall, not all the other stuff....

  16. InfoCynic
    Member
    Posted 8 years ago #

    I was having trouble with this too (using the free ZA w/Apache 2), and I turned the slider for Internet Zone Security down to medium, and things seem to be better.

  17. xcrookshanksx
    Member
    Posted 8 years ago #

    Thanks for the tip stevhill. Adding my site in the Zone Alarm privacy panel and allowing private headers did the trick. And I didn't have to reduce overall security for the internet zone.

  18. Doodlebee
    Member
    Posted 8 years ago #

    when you added "localhost" to the trusted sotes - did you type in "localhost" or did you type in the IP address?

    The IP address for "localhost" is 127.0.0.1. Maybe if you enter that IP as trusted, it'll work?

  19. spankyMcFea
    Member
    Posted 7 years ago #

    Had the same problem -- could never login using ZoneAlarm Security Suite -- problem is that if any of its "privacy" settings are on at all, it will still block localhost and 127.0.0.1, even if you enter them as sites. So, turn those settings off while working with WordPress locally.
    Here's more:
    http://forums.slimdevices.com/showthread.php?t=30588 with a link to the ZoneAlarm forum.

Topic Closed

This topic has been closed to new replies.

About this Topic