WordPress.org

Ready to get started?Download WordPress

Forums

Scrappy
Zend (11 posts)

  1. robi9832
    Member
    Posted 1 year ago #

    Which Zend does the Scrappy theme use? Is it Zend Guard or Zend Optimizer?

  2. ClaytonJames
    Member
    Posted 1 year ago #

    Zend Guard and Zend Optimizer are programs used to obfuscate and then run, or decode, the obfuscated php source code.

    Are you asking because you believe you have found php code obfuscation in the theme?

  3. robi9832
    Member
    Posted 1 year ago #

    I have a plugin I want use in WordPress. I have use the theme and the plugin on another site but when I updated WordPress I get an error message about the theme and Zend. O contacted my host provider he told me to verify which Zend to use because it can cause site to crash

  4. ClaytonJames
    Member
    Posted 1 year ago #

    when I updated WordPress I get an error message

    What version of php is your web site using?

  5. robi9832
    Member
    Posted 1 year ago #

    Version 5.3.14

  6. ClaytonJames
    Member
    Posted 1 year ago #

    You mentioned a plugin that's involved, a WordPress update that caused the error, and an error message that's related to the theme. So it might be the theme, it could be a plugin, or it could just be a bad host.

    If you copy and paste the exact error message here so someone else can see what it is, and also include the name of the plugin that you have concerns with, someone might recognize the problem and be able to help.

  7. robi9832
    Member
    Posted 1 year ago #

    TDM Traffic Plugin:

    Plugin could not be activated because it triggered a fatal error. Zend Guard Run-time support missing!

    One more more files on this web site were encoded by ZendGuard and the required run-time support is not installed orproperly configured.

    For the Web site user

    This means that this Web server is not configured correctly to runthe files that it contains. Please contact the Web site'sadministrator/webmaster and inform them of this problem and give themthe URL you are trying to display to help them in diagnosing theproblem.

    For The Site Administrator/Web Master

    One or more files on your site were encoded with Zend Guard. Thismay be third party libraries that were provided to you by an ISV. Toallow these files to properly run you need to download and installone of the Zend guard run-time libraries. This is either ZendOptimizer or Zend Loader. The proper files can be downloaded fromhttp://www.zend.com/guard/downloads.This software is provided free of charge.

    General Disclaimer: Zend Technologies is not responsible tothe configuration and setup of web sites using Zend Guard technology.Please contact your software vendor if these components were providedby an ISV or consult your Zend Guard Users Guide if these files wereencoded by your organization.

  8. robi9832
    Member
    Posted 1 year ago #

    I contacted my host & the rep stated it's the theme but I have used it successfully previously

  9. ClaytonJames
    Member
    Posted 1 year ago #

    That message in its entirety is amazingly specific, very instructional, and extremely self explanatory. The plugin appears to quite clearly be the cause of the error. It appears to have nothing to do with the theme or with WordPress, and your host just plain doesn't want to be bothered with it.

    Call your hosts back and ask them how to enable the extension (ZendGuardLoader) in your php5.ini file. Better yet, ask them to do it for you.

  10. robi9832
    Member
    Posted 1 year ago #

    Wow, thank-you! The host made it seem that it was the theme. I couldn't understand why it worked once then after an upgrade it didn't. When he told me that the site might crash if I installed the wrong one I wanted to cross Ts & dot Is.

  11. robi9832
    Member
    Posted 1 year ago #

    The host provider fought me tooth and nail but I was adement about holding them accoutable for this issue. At first they only emailed me the instructions stating they could not change the file for me. Then the rep attempted to blame the the plug-in creator. Then finally I made my point clear that the buck is stopping with them. So the rep finally gave in and walked me through the process.

    http://support.godaddy.com/help/article/7910/disabling-apc-on-your-hosting-account?locale=en&ci=46061

    http://support.godaddy.com/help/article/6893/using-zend-guard-loader?locale=en&ci=46061

    ** You have to rename the current php.ini or php5.ini file to something else then create or modify the php5.ini; php.ini will not work.

Topic Closed

This topic has been closed to new replies.

About this Theme

About this Topic