WordPress.org

Ready to get started?Download WordPress

Forums

Editorial Assistant by Zemanta
[resolved] Zemanta Image Caption can't be edited on WP media editor (6 posts)

  1. meekyhwang
    Member
    Posted 4 months ago #

    We have a Zemanta plugin (PRO account) for WordPress 3.5.2. We recently upgraded the plugin from 1.1.2 to 1.2.2, and noticed the image-settings, have and issue with the default WP's media editor.

    On a new post, when a new image is inserted from Zemanta and immediately open the image edit modal (from view tab, clicking the "edit image") and trying to update the caption, the caption won't be updated.

    Please keep in mind that since on image click, it opens up the image settings for the inserted image, and double click will open the media modal.

    However, we noticed that once the post is saved, or if I switch to a text tab and back to view tab, I can update the caption through media editor.

    Is this a glitch or known issue that would be fixed on the future release?

    http://wordpress.org/plugins/zemanta/

  2. WPyogi
    Volunteer Moderator
    Posted 4 months ago #

    If you have a paid version, please contact the developer(s) directly - as these forums are only for free plugins.

  3. Mateja
    Member
    Plugin Author

    Posted 4 months ago #

    Hey,

    I'm not quite sure what you mean by PRO account - we don't offer a paid (or PRO) version of our plugin.
    From what you describe this is not a known glitch, so I'll try to reproduce the error.

    Best,
    Mateja

  4. meekyhwang
    Member
    Posted 4 months ago #

    if you look through the plugin code, in zemanta.php
    There's a section to set up the pro account information. I might not be using the correct term, but the code snippet I see is,
    /**
    * is_pro
    *
    * Check if the plugin upgraded to PRO
    */
    protected function is_pro()
    {
    return defined('ZEMANTA_API_KEY');
    }

    /**
    *
    * Load Zemanta pro plugin settings
    *
    */
    protected function check_pro_settings()
    {
    if(file_exists(dirname(__FILE__) . '/APIKEY.php'))
    require_once(dirname(__FILE__) . '/APIKEY.php');

    if(file_exists(dirname(__FILE__) . '/prosettings.php'))
    require_once(dirname(__FILE__) . '/prosettings.php');

    if (!defined("ZEMANTA_API_KEY"))
    return false;
    else
    return array('api_key' => constant('ZEMANTA_API_KEY'));
    }

    And we do have these settings set up. I also emailed zemanta service as well to find out more. Any help would be appreciated.

    Thanks,

  5. Mateja
    Member
    Plugin Author

    Posted 4 months ago #

    Hey,

    this piece of code is not related to the issue you're experiencing and it serves our internal purposes.

    However, we can confirm that issue with editing captions you're experiencing is now a confirmed issue and we are already working on fixing it.

    Thanks,
    Mateja

  6. Mateja
    Member
    Plugin Author

    Posted 1 month ago #

    I'm closing this topic as this issue has been fixed.

Reply

You must log in to post.

About this Plugin

About this Topic