WordPress.org

Ready to get started?Download WordPress

Forums

Editorial Assistant by Zemanta
Zemanta BUG - Screws up screen options. (8 posts)

  1. rhythmdoctor
    Member
    Posted 3 years ago #

    Ever since uploading and activating the Zemanta plugin last night, the user screen options will not save on the dashboard or on the post pages.

    Here is some more information. I can see the options within the user-meta table but they never change. I even tried to create a new user to see if it would work and it does not. Ajax seems to work fine within wordpress and I have tried all the suggestions listed at http://wordpress.org/support/topic/164999

    I have tried to save these screen options in IE, Firefox, Chrome, and Safari so it doesnt seem to be brower dependent.

    I know that this is the Zemanta plugin that causes the error as I installed a new version of wordpress and tried it and Zemanta was the only plugin I installed.

    Furthermore, it seems to make a permanent problem because after using the plugin once, even after disabling and deleting the plugin, the problem remains.

    Appreciate any help as there are a ton of options, especially within post pages that I do not want to be shown and would like to reorder boxes so that, for example, I dont have to scroll all the way to the bottom of the page to choose my tags.

  2. Daniel Haim
    Member
    Posted 3 years ago #

    Hi Rhythmdoctor, welcome to the WP Plugins and Hacks forums.

    Visit your PhpMyAdmin and drop the Zemanta table completely, remove it from your Plugin directory and see if the problem persists. If it does, I recommend to re-download the WordPress 3.0 folder and upload everything besides

    • wp-content
    • wp-config.php

    Also, just to clarify - you are saying that aside from nothing saving the AJAX on the dashboard has stopped working? It sounds like that something has messed with your core file. Also, - are you getting a blank screen after trying to publish?

    Good luck.

  3. rhythmdoctor
    Member
    Posted 3 years ago #

    wow - very great and speedy response. Thanks for that.

    OK, so as for Ajax - no, all works except saving screen options.

    As for the database - I dont see any table for Zementa - do you mean the entries for it within the wp-options table?

  4. Zemanta
    Member
    Plugin Author

    Posted 3 years ago #

    Grrr. Sorry about this. We are way behind on fixing this - lack of resources. Bear with us please!

    Best,
    Rok

  5. Zemanta
    Member
    Plugin Author

    Posted 3 years ago #

    This is now fixed, everyone! Update your plugin to 0.7.0. Thanks!!!

    Rok,
    Zemanta

  6. rhythmdoctor
    Member
    Posted 3 years ago #

    Yipee, thank GOD. Unfortunately, here's what I need for it to work for me. I need it to allow me to default to our own content and not the web content. Id still like that as an option but I need my writers to use it to help them find our own content primarily, and then the zemanta web content optionally. Is there a quick fix that i can use to accomplish that? Thanks.

  7. Zemanta
    Member
    Plugin Author

    Posted 3 years ago #

    Hey,
    if I understood this correctly, you want your own content (your articles) to come up first? That could be done with using the "My Sources" tab, if you are using that option.
    Otherwise, I don't see how it could be done.

    Could be that I didn't understand the question, though.

    Thanks,
    Rok

  8. rhythmdoctor
    Member
    Posted 3 years ago #

    Rok, thanks for the quick response. Yeah, I guess what I mean is it would be nice if I could choose for it to first show the "my sources" tab as the default. When I activate it and then go to a post, I have to click on "my sources" tab to get that part of it, but Id rather not have to have my writers click on the tab because knowing them (hopefully they dont read this), they'll forget.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags