WordPress.org

Ready to get started?Download WordPress

Forums

Responsive Video Embeds
Youtube video not working responsively (6 posts)

  1. natasmarketing
    Member
    Posted 4 months ago #

    Hi, I have embedded a video from YouTube and installed your plugin, but it does not seem to be working responsively

    Please see the page:
    http://dev16.nd-marketing.com/?p=165

    Can you help?

    thanks

    d

    https://wordpress.org/plugins/responsive-video-embeds/

  2. emirpprime
    Member
    Posted 4 months ago #

    I found the plugin didn't work until I commented out the if ( ! self::$do_enqueue ) check in the source. Hopefully the author will publish a fix soon.

  3. wiziwiz
    Member
    Posted 4 months ago #

    where do we edit out the code please ....

    if the plugin dosen't work why is it still live?

  4. emirpprime
    Member
    Posted 4 months ago #

    To edit the code you need to comment out (or delete) line 68 and line 69 in responsive-video-embeds.php

    Make sure you have FTP access to the site, even if you make the change using the admin area plugin editor. If you mess anything up, worst case you won't be able to access your site - but by going in over FTP and just deleting the plugins' folder from your /wp-content/plugins/ directory you'll be back up and running.

    As to why the plugin is still live - it's just a bug, and these are free plugins, mostly developed in people's spare time. It can take a while for fixes to get made.

  5. SpenceDesign
    Member
    Posted 3 months ago #

    @emirpprime you saved my bacon. Thanks for the tip on removing the 2 lines of code.

    The other thing that should be noted for anyone having trouble, is that this plugin only works (after above mention code is removed) with the built in video embed feature in WordPress. If you use the iFrame embed, it does not work properly (will not scale like it should).

    Bummer part is that you cannot prevent other videos from showing at the end of you videos unless you use the iFrame embed. If anyone figures out a workaround to the "rel=0" option for auto video embed, let me know. I have yet to find one.

  6. SpenceDesign
    Member
    Posted 3 months ago #

    Update to not showing related videos for built WordPress embed. Use this plugin, instead of having to add the ?rel=0 to every video link. The plugin I am using to post listings was striping the ?rel=0 out and thus still showing related videos.

    Plugin that fixed the showing of related videos:
    http://wordpress.org/plugins/hide-youtube-related-videos/

    Cheers!

Reply

You must log in to post.

About this Plugin

About this Topic

Tags

No tags yet.